Jump to content

'76 620 that loves to run - it won't stop!

Recommended Posts

I've got an odd problem; I've tried some things already, so here we go.
It's a '76 baby blue 620 with 58k original miles.
Didn't drive this much, probably once a month or so in past two years. It was the lumber-yard & 'to the dump' truck.
Last weekend I needed it, as my commute car failed ('98 Honda with 250k!).
I charged the battery, drove it up to the garage and adjusted the front brakes (previous issue & unrelated?).
Being a duppas, I left the ignition on while I did the adjustment, so had to charge again.
Started right up, drove 150 yds and back - brakes good, ran good.
Parked at garage, turned off the ignition, and pocketed the key... still running great.
Note that last part, 'still running great', not dieseling, it ran.
I got out, lifted the hood, thought, ‘how do I stop this?’.
Using the service manual, pulled the ignition switch from the column, and unplugged from the harness.
With the key and switch laying on the floor – it is still running!
Went into shop, got glove, rag and channel locks – pulled high voltage out of distributor – as it died, I had full power ¾ inch sparks! 
So, now that’s mystery. 
Here are more ‘hints’.
This is ‘California’ wiring model.
I have; 
power at the B side of the coil when the thing is running (key in run position)
zero at the top of the coil when the engine is still.
power, when the thing is running in ‘phantom mode’.
So I deduced that the power is coming from… the Alternator! (power when running, nothing when still)
It has got to be the regulator (an aftermarket CarQuest brand potted electronic thing).
Replaced it – no joy.
Study the factory manual (yeah I have one) schematic, the entrails did not speak to me.
Discuss with friend, find and unplug the ignition relay – that DOES kill phantom mode! But doesn’t tell me much. When the key is turned, the relay ‘clicks’, on & off. When the engine is running, and the key is removed, there is no click. If I stall the engine (put it in gear and bog it down), the relay drops about the moment the engine dies. The coil side is on the ignition switch side, the switch is on the battery side.
BUT, the ‘Charge’ light is off when running (key or phantom), and off when key is off and engine dead. So the relay can’t be shorted.
(I pulled the relay, disassembled, and checked operation. Clear - no shorts.)
Study the wiring diagram, (ouch my eyes AND head hurts) – again, no clear thing jumps out.
Under the assumption that this is a shorted diode, and since I replaced the regulator….
It has to be a diode in the alternator – nope, had the parts store check it – it passed.
(and here I want to shout out to Penn Valley Dimer, he discussed, ordered parts and turned me onto this forum! Thanks)
So, to summarize, the 620 runs without a key. It’s not, the ignition switch (runs when removed), the regulator (replaced), alternator (tested). As it is stable and repeatable, I have trouble believing a wire short (can’t be short-to-ground this is a hot-side issue, yes?) the only other ‘electronic’ (containing diode or solid state devices) is the ‘ignition transistor amplifier’. But it gets power from the ignition switched side of the power loom.
Mr. Dimer said this would be solved by a Mr. Klotz (a master and learned sage) but this is probably as much magical as an electrical problem. 
As this is not the primary vehicle, I can do diagnostics where requested. Any takers?
Friday hint: removing the 10Amp fuse labeled ‘Solenoid’ from the Ignition switch side of the fuse box THAT kills the engine… that goes right to the regulator….
(Currently on blocks - I blew a freeze plug. But I can still do tests.)
Hay, I guess my truck thinks it's a horse, it wants to sit in the barn at idle. No donkey jokes please!


Link to comment
  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Yeah, that was my first thought, too. First thing I did - I yanked the 'CarQuest' potted thing and replaced it with a OEM style relay type. No change in symptoms. I took it in to get the Alternator tested (primarily for the diodes, but it checks other functions - including regulator) it passed... 

Hmm. So you are recommending I unplug the regulator? (Can I do that without damaging anything?) Since all the alternator power flows through it, I expect that would mean I'm running off the battery alone - and things would work as expected. What would that indicate? Two bad regulators?

Sigh, I suppose it could be true. This thing is pretty goofy.

Gimme a couple hours and I can run a test.

Link to comment

"All the alternator power" does not run through the regulator. It runs through the fat wire connected to the back of the alternator which goes straight to the battery via the fusible link.


Yes, disconnect the regulator, start the engine and then turn the key off. If it keeps running, its not caused by the regulator.

Link to comment

I stand corrected (grovel, grovel)!

I did as you recommended, disconnected regulator, started, turned it off and..... it stopped!!

Wow, WTF, and other TLAs.


So is this the test for a bum regulator? Should I replace this for a second time?

Is there a diode I'm blowing in the regulator - I mean, is there something that 'eats' regulators?

Something I can replace to limit the number of regulators I go through?



Link to comment

That test only verifies the problem is related to the charging system. It doesn't tell us the cause, which could be alternator, regulator or wiring.


The most common cause is the wrong alternator has been installed. But if you didn't just change that we can rule it out as the cause.


Sometimes when wiring has been modified this happens. If you haven't changed wires then that's not it.


The regulator turns the dash lamp on & off. To decide it uses a weak signal from the alternator N wire. The alternator diodes are not involved.


So that leaves the regulator. New chinese ones sometimes are bad right out of the box.

Link to comment

Yes I've heard also that putting an internal regulated alternator on an external regulator will not shut off



Unplugging the regulator shuts down the field current and this likely is what shuts off the charging. Maybe something stuck inside the regulator? Turning the key off should turn off the field current.


Perhaps if jumped the alt would have to run at full charge and this froze the alt?

Link to comment

Thanks for all the input, for the record (and the next poor slob down this path)....


- I charged it with a older craftsman battery charger. I had been doing this irregularly, with same equipment, as this vehicle is driven intermittently (like when I need to go to the dump or the Home Despot). Been doing that for the past half dozen or so years with no ill effects. And no, ggzilla, I did not reverse the cables. (knock on wood - I pray I never do. Grew up in the Rust belt/Snow belt - learned to use jumper cables about the same time I discovered a clutch!) 

- There has been no electrical service for at least that long. The last bits worked on, brake master and two wheel cylinders (brake fluid sits long enough, the water sinks to the bottom, rots out the bottom of the cylinder). The bypass (?) hose in the front of the engine split a couple months ago, sprayed the front with water. Since then a freeze plug popped out. But I don't see anything related to the charging circuit.

- After I left the ignition on, I changed the regulator. So if Datsunaholic is right and I cooked the old CarQuest potted thing, then the new one was bum, the same way, right out of the box, like ggzilla said.


Harumph, I guess I'm down for another regulator.

Thanks for the discussion....

I'll let you know the results in a day or so.

Link to comment

I found it (I think!)!


I ordered ANOTHER regulator (and debated the conversion to a chevy generator)....

But somehow it did not feel right.

Looked at the schematic, there is no diode in the regulator - so how could this be the source of the problem?

I popped the cover on the regulator and confirmed both relays were moving and not shorted.

I even manually toggled the relays, still didn't kill the engine.

So, I considered the entrails, er schematic once again.


As my eyes blurred I said chuck-it! and (in addition to the colors I did before) I started erasing all the 'junk' - headlights, markers, etc.

That's when I saw an odd bit of connections on the 'A.C. Heater relay' - Uhm?

There is no Air Conditioner, and why would it need a heater? - and why would it go right to the alternator and regulator?

(For the record, I will try to attach my semi-completed diagram.) The wire that caught me was the green line on page 1.




To make a long story short - if I unplug the Automatic Choke Relay, this issue is fixed.

Plug it back and the problem returns.

I haven't figured out HOW, but this is the root of the issue.

Thanks to everyone, I will do a post-mortem wrap up in a day or so.

This one is just weird!

Link to comment

The automatic choke relay is powered only when the alternator is charging. It uses the same signal that turns off the ALT light on the dash to turn on the choke heater relay (the AC Heater relay).   So, if the regulator is stuck (or the alternator has an internal short, or the wrong alternator is used in some cases) then it will keep power to the auto choke relay even when the ignition is cut.  The issue is that the auto choke relay and the ignition are being backfed power from the alternator's field terminal, when the ignition should cut that off via the regulator.  Unplugging the auto choke relay breaks the loop, but that's only solving a symptom (and causing another if you have an electric choke still installed).   


If the auto-choke relay or the alternator itself were the culprit, you'd have a constant drain when the ignition was off (and the engine not running).   

  • Like 1
Link to comment

Unless ... the relay is stuck in the on position, powering the choke whenever the IGN is on. You're right, its not supposed to do that. It won't drain the battery with IGN off as the relay is not connected directly to the battery.


A simple test to rule this out is to plug it back in. With key On engine Off the brake warning lamp in the dash should light . If it does, the relay is not stuck in the On position.

Link to comment
  • 4 months later...
A bit more followup (sorry for the delay - blown head gasket interrupted the electrical problem!)...

Just to close some items raised - 

No, the battery does not drain when it sits - couple weeks at a time, still strong.

The Brake Light is lit, Key-on or Engine-running, IF the brake is pulled. 

The Charge light also works like expected.


I did unplug the A.C. relay. That fixes things - so I poked around with the VOM:

(Pls note: as Road Warrior pointed out, A.C./AC is the Automatic Choke.)

With the power off, there is continuity to ground on all four pins of the AC relay connector. 

(note: this continuity exists even if the AC is unplugged !! Look at diagram - should not be so.)

With power off, there is no voltage on any pin.

With power on, there is 12v on BOTH lines leading to the contacts of the relay. Nothing on the other pins.

With the engine is on (running), 12v on the contacts, 7v on one of the coil pins. (7v looks about right, this is the charging voltage (?))

Unplug the AC - check on it's single pin connection - 12v there, too. 

This is with the power on, but the relay unplugged.


There does not appear to be any damage to the wire harness - there has been no damage, smoke or cuts I can see. But it sure looks like a short from +12 to one side of the AC part of the harness.... 


But, what does that have to do with the engine NOT shutting down???? :confused:


Since this thing is now road-worthy (without an AC relay). I am willing to do any tests. Anyone want to chase this? 

If not, I'm gonna call this 'resolved - but not solved' and move on.

Thanks everyone.  :thumbup:
Link to comment
  • 4 weeks later...

I've found the charging system setup on both my rigs extra annoying.

I ended up Chevy 3 wire alternatorizing both of them and getting rid of the heater relay and external regulator bullshit. My choke heat is now just switched 12 volt with ignition and the field and idiot light wires go to their appropriate locations. Now my lights don't dim when I signal, and I can have lights, heat, wipers and stereo on at the same time without killing the battery.


On the first 620 I had years ago it did this, after replacing all the datsun stuff and still having problems that one got chevyized too.


In my years of datsun owning I've killed about 7 alternators and at least 4 regulators.



With gm alternators now I've had one go bad, pretty sure the rotor in it wasn't balanced and it vibrated to death as the case blew apart :P


Link to comment
  • 4 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.