Jump to content
Sign in to follow this  
Aibast

Aibast - 1996 Land Rover Discovery1 Tdi 4x4

Recommended Posts

Got to do the front to. Not a lot of pics, as I was outside and started to rain. Didn't want my phone to get water and oil damage.

Changed the old cracked and rusted oilsump to new used one. Also new heavyy duty springs and shocks to with poly pushes. 

And got trough the annual inspection with good results. Everything was OK for the car to be safe and used on the road. 

large_29703119_dXjZ.jpg

Liftoff

 

large_29703121_6FVi.jpg

The old stuff on the car.

 

large_29703123_W1Ba.jpg

Next day,, this is how the car sits now. Nice high and tight. No more excess suspention play.

 

large_29703125_YzCS.jpg

New stuff on. Just front panhard rod needs new poly pushes (I have these also waiting for install).

Share this post


Link to post

Well, a bit off topic, but one old guy in here, offered me his old Datsun 720 or D21 don't know what it is, but for a real good price with 3.0 diesel engine. Got to go and take a look :)

Share this post


Link to post

Update - the truck is Nissan Pickup (1987 D21? )

It is still solid and usable. 

large_29712979_HAZd.jpg

large_29712971_FzH8.jpglarge_29712973_8bml.jpglarge_29712975_eVIk.jpglarge_29712977_vPVI.jpglarge_29712981_fd3Y.jpg

large_29712983_LPLX.jpg

Share this post


Link to post

Managed to get all my cars on one picture. Renault Master is a new addition. Wanted something with more space. It's a 9 seater minibus with 2.8L turbo diesel. Uses less fuel than my 4x4. The Land Rover will be on sale soon. Just need to fix some minor problems. Like leaking exhaust sticky handbrake and leaking front crank seal.

 

Behing the 4x4 is a Peuget Boxer van also 2.8L turbo diesel.

large_29751645_OdTq.jpg

  • Like 1

Share this post


Link to post

well, my van sprung a coolant leak.

large_29755977_YYtm.jpg

Had to tear it down a bit to check what is wrong.

First removed the bumper. Broke all the bolts that held it in place. They where all rusted up real bad.

large_29755975_KyLv.jpg

 

Next of with everything else that was stuck on the front part holdin in the radiator and the intercooler.

large_29755979_rcGK.jpg

 

and found the cause of the leak.

large_29755981_KF0r.jpg

 

Ordered some new parts and this is how it now sits, faceless "frog eater"

large_29755983_8Okg.jpg

Share this post


Link to post

Got my "Master" together again with some cosmetic changes as well.

large_29756797_nZsT.jpg

PS. Used all new stainless nuts,bolts and washers for fastening.

  • Like 1

Share this post


Link to post

Good to see it back in action!

Share this post


Link to post

Why is it that every time a buy a car, they start to have strange issues. Today vans heater fan failed on me. Just another thing to fix.

Share this post


Link to post

Heater fan fixed. Speed swich had a bad connector. A little cleanup of pins and it works again.

Share this post


Link to post

The van failed on me again, this time the fuel filter heater element leaked air in the fuellines and the pump went empty, so no start. It took me a whole week to find out what caused the airleak. But it had a good side to it. I got to drive my Disco in 30cm of sluchy snow = fun fun and more fun, drifting around.

large_29760889_1DuX.jpg

Share this post


Link to post

Vans running again.

large_29761821_bYGp.jpg

 

having more snow in here every day. It makes everything take longer, forklift gets stuck all the time and so on.

large_29761823_wc2u.jpg

PS. Need to start working on my oldtimer, just 2 months to this years winter rally

Share this post


Link to post

Went for a little drive in my Disco. First to my summerhouse (100km or 1h drive). What I found was that the old oak tree had loosed a limb and it just missed the house when falling down.

large_29764605_eKLj.jpg

large_29764607_xMjo.jpg

On a good side - all my bees are a live and well. Only 3 more months to go for them to get forraging again.

 

Then went to my small pach of land to get a spruce for "xmas". The road wasn't that bad, a little mud and a lot of water. Didn't risk the water as I have no winch on the Disco. Been stuck in dry times there and didn't want t get stuch when wet and cold. So parked the car on solid ground and hiked from there.

large_29764603_A6cF.jpglarge_29764601_wpUP.jpg

 

https://youtu.be/mZuBGC8Nd1M

Share this post


Link to post

well, my vans muffler broke today. Some A hole had some time welded in a new cat and damn I know I can't weld but damn these where some bad welds. As I had nothing else to support the thing under the car I used one of the cargo straps I had in the van. 

large_29768181_O3v4.jpg

large_29768179_KTmp.jpg

  • Like 1

Share this post


Link to post

exhaust is now fixed.. This is why it failed. Damn there are some not so smart people around large_29768557_qPk6.jpg

The exhaust was velded together by a clamp. That was it nothing else. I cut that off and velded on a new connection and properly clamped that thing together again. Works fine now.

Share this post


Link to post

So no more Land Rover for me. Changed it to a Volvo 740 "van"

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.