Jump to content
Sign in to follow this  
ratsun.818

620 turn signal

Recommended Posts

Hello everyone so only my left turn signal turns works when I hit the switch. Yet when I try to signal right the light in the cluster and the light on the turn signal don't come on. However, the hazards work perfect. I have an extra used turn signal switch I found lying around but it's funny because it works vice versa (left signal doesn't work & right signal does work) so technically, do y'all think it's just the turn signal switch? Thanks in advance m8's

Share this post


Link to post

Yup.... it's probably a broken solder on the switch or just not making contact.... on my 521 it slide on a plastic contact plate .... mine broke so only half worked also... take a closer inspection and you should see something either broken or corroded....

Share this post


Link to post

By your description, it's the switches. They appear to have the same problem but on opposite sides. The 620 shares the turn signal with the brake light so the switch disconnects the brake on that side before connecting the flasher to it. If you watch you can see the contacts open before connecting to the flasher. Mine had huge blobs of solder on the wires. One came undone but it was an easy fix. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.