Jump to content

Carburetor issues

Recommended Posts

Hey dudes,
So I am having an issue with my 1978 Datsun B210, On my way to work yesterday just driving normally, I feel it lose power, I floor it and it came back. Only while the pedal is floored though. Zero part throttle power (doesnt even stay running unless I keep pumping the gas. I figured something was blocking fuel to the primary, so I pull the carb apart and found nothing, Re assembled with new gaskets and a new power valve. Got it back on the car and the same shit happens, I've checked most of the vacuum lines and nothing is even helping a little. Got any Ideas? (I live in an apartment so no fancy tools here)

Link to comment
  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

I was having Carb issues for a long time with my 74 B210, I did a ton of research and was even thinking about buying a new webber, but after a few months of mulling it over (and the fact that I had a total knee replacement) i stumbled upon something while out sitting in my car and running it.  I noticed that my temperature gauge never went up.  I did some research and it turns out that the temp sending unit that goes from the engine block to the gauge also sends back a signal to the auto choke on the carb.  Because it wasn't reading that the engine was coming up to the right temp it wasn't opening the choke, and my idle sucked, and i was having all the same issues you are describing now. 


I bought a new one from rockauto, was like $10 with shipping.  When i took off the old one it looked like the PO had wrapped the threads in silicon tape (I'm assuming to keep it from leaking).  The tape was blocking the ground on the engine and the sending unit failed.  Soon as I plugged in my new sending unit and started it up, my temp gauge shot up to half way and stayed steady, after about 5 minutes my idle evened out and it's been running fantastic ever since.  


Of course I haven't been able to actually drive it seeing as my knee is messed up right now, but every time i start it up, it warms up and bam.. perfect idle, no jumping around no power loss... it's beautiful.


Thought I'd throw that out there.

Link to comment

Did you find dirt/sediment or water in the float chamber???



The idle circuit is totally separate from everything else so it should still idle even with the primary plugged.


Look for a large vacuum leak like the brake booster hose. Get someone with needle nose pliers to pinch any hose attached to the intake while you start it and see if there is improvement.


Doubtful but...

Check that the EGR valve is closing. (it should be closed at idle) On a non running engine, you can reach up under the ERG valve with your fingernail and lift up on the plinth rod, and let it drop. It should move. If not moving it can be unbolted and wire brushed to remove crusty exhaust deposits that may be holding it open.

Link to comment
  • 2 months later...

"Did you find dirt/sediment or water in the float chamber???"


A little dirt, at the base of the fuel bowl, I cleaned all that out and cleaned out the jets even though they looked fine. Replaced all gaskets as stated above.


"The idle circuit is totally separate from everything else so it should still idle even with the primary plug."


I figured this as the idle mixture adjustment didn't seem to affect part throttle at all.


"Look for a large vacuum leak like the brake booster hose. Get someone with needle nose pliers to pinch any hose attached to the intake while you start it and see if there is an improvement."


Got rid of all hoses and replaced with new. Replaced the Intake Manifold Gasket, the gasket between the Intake manifold and the exhaust manifold heat riser. It will run fine in the garage and doesn't start acting up till I start moving. After a short distance, I feel power drop off and then it just wants to die with part throttle, it will idle its way home, and then once its shut off and started again its fine. 


float level is fine


Idle cutoff solenoid is fine


choke gets set with throttle application and opens as the engine warms


Should I just get a Weber, or does this not sound like a carburetor issue at this point.


"Check that the EGR valve is closing. (it should be closed at idle)"


Blocked off as I broke the feed line from the exhaust manifold during this troubleshooting, fitting on the EGR manifold broke when removal was attempted.


I guess it has improved since original, it does not die unless the gas pedal is applied, it just bogs down. and still the same story of the accelerator pump will slowly boost RPM high enough to keep it floored (after many pumps) but from even a little throttle input to just under full throttle, the gas pedal acts like a kill switch. Plugs indicate shes rich after this happens. So maybe the carburetor is dumping too much fuel at part throttle?


The car had sat for many years in front of the second owner's house since the early 1990's only has 37000 miles.. I was surprised how clean the carburetor was before I cleaned it (not that, that did anything)


I'm at a loss...

Link to comment

As you step into the gas pedal. If it 'falls on it' face says there is no gas or a restricted amount getting to the primary venturi. If the jet is not blocked then the jet it too small (should be around 100) or there is still some blockage in the circuit.


Take the air filter top of and while attempting to rev the engine very quickly, you should observe a misty white spray come out of the venturi. Do not confuse this with the single squirt from the accelerator pump.


Hainz's suggestion is to rev the engine and quickly clap a your hand with a large rag over it onto the top of the carb. This will cause a huge suction that may draw through any blokage.

Link to comment
  • 2 weeks later...

Thank you datzenmike for your help, none of that worked, I installed a weber 32/36 and now she runs great again, for the life of me I cannot figure out what gave up the ghost on the original carburetor I even took it apart and cleaned everything again and it was still being a bitch.. so I bought the weber.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.