Jump to content
Sign in to follow this  
mx71

Separating power steering reservoir from pump?

Recommended Posts

I got a squeal in my pump and I've got my new one coming today, but I can't get the reservoir separated from the pump. Is there something I'm missing? I don't see anything holding it on.

Share this post


Link to post

Since you didn't provide pics, I went and looked at pics from RockAuto.

 

 

It looks like there are bolts? that hold it in. Or is that where the return line goes. If not, it's held in by an o-ring.

 

 

GL.

Share this post


Link to post

All bolts are removed. Both lines are removed. I also looked at the diagrams.

  • Like 1

Share this post


Link to post

How many o-rings came with your kit?

 

Should be one for the return fitting and one for the bottle. Two washers for the pressure line.

  • Like 1

Share this post


Link to post

I found it. There were two additional bolts I missed that were caked in mud/other stuff. Also, turns out that the reservoir extends all the way down to the bottom of the pump, rather than just sitting on top like I thought it did.

  • Like 2

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.