Jump to content

No brake lights.


Recommended Posts

Ok so I got no brakes lights on my 620. I replaced the brake switch thinking an easy fix. But that did not seek to work. All other lights work front and back. Any ideas Ratsun members?

Link to post
  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Which one '74 or '77?????

 

Does your horn work??? If not the fuse is blown. It's the 15 amp left side closest the dash.

 

 

 

Link to post

Or 2 burnt out bulbs.  I had the same problem many years ago.  After tracing the  wiring etc.  I checked the bulbs just for the hell of it.  DOH !  Don't remember how many hours I had wasted, but I know every where my wiring harnesses hide.

Link to post

If the turn signals work then the bulbs are ok. Signal and brake take turns sharing the same filament.

Link to post
7 hours ago, datzenmike said:

If the turn signals work then the bulbs are ok. Signal and brake take turns sharing the same filament.

Well dont I feel foolish...it was a blown fuse. Problem fixed. I looked at them Just not good enough. Thanks Mike..sure I will be back again with questions..soon. 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.