Jump to content

Compression in my J13 engine


Rusty Dawg

Recommended Posts

Howdy all,

 

I am in the process of getting my engine running again, but before I do so I did a compression test on my cold engine and my readings after only 4 turns were the following:

 

Cylinder 1 - 110

Cylinder 2 - 110

Cylinder 3 - 108

Cylinder 4 - 127

 

Is it worth continuing to get her started or should I look to fix what seems to be low readings? (rebuild?)  The information I have is that compressions should be a minimum of 128psi with a deviation of 10-15% from the lowest reading to the highest.

 

Warm regards

  • Like 1
Link to post
  • Replies 91
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Only one is close to the minimum.

 

Try a couple of spoonfuls of engine oil in the spark plug hole. If the rings are bad this will seal them and the compression will jump meaningfully higher. If not much change it could be the valves and seats are pitted. Lapping the valves is cheaper than rebuilding the block which won't really do much. 

 

If you have a compressor you could borrow a leak down tester. This pressurizes the combustion chamber with compressed air. If the rings are bad air will blow out the breather cap on the valve cover.  If an intake valve is leaking there will be a hissing sound from the carburetor throat. If an exhaust valve is leaking you will hear it through the exhaust pipe. It might be a combination of all three.

  • Like 1
Link to post

If motor has been sitting forever , I would get it running best you can .. Run up to temp a few times .. then test 

  Why start by rebuilding ? Maybe it will run just fine even with crappy/uneven compression,, you never know. 

 

j13 don’t have very good comprehension on a good day but should be somewhat even . 

  • Like 2
Link to post

If comprehension is low but even and if not blowing a blue cloud.... drive it. Compression will probably rise slightly with some use. My old L16 in my 521 was around 120 and it used oil but not a cloud of it. It ran just fine. Later I honed the cylinders and put new rings and bearings in it.

  • Like 2
Link to post

As someone who just replaced head gasket I agree, drive it and watch for symptoms. And maybe check your compression periodically. The first symptom with my blown head gasket was exhaust blowing coolant out the radiator overflow.

 

  • Like 1
Link to post

The throttle was not wide open when I ran the test.  I disconnected the coil wire and turned it over 4 revolutions per cylinder.  I have spark at the spark plug, so once I place some engine oil in each cylinder I will try to get her going.  A local import mechanic told me to do the same thing and pour a little oil in each cylinder and try to start it.  Also, he told me that I should've have done closer to 10 revolutions per cylinder for my test.  Since it's been over 8 years since it ran, he said that I might be just fine once I run it a while🤞

  • Like 1
Link to post

I've done this with and without the throttle open and saw almost no difference.

 

Yes running it will oil the rings and polish the valve and valve seat. It's never going to be new but it might go up some.

  • Like 1
Link to post

If you just break it down and rebuild it, you'll always wonder how it would have resurrected if you don't give it a shot. When I acquired our 320, I knew the E1 was loosy-goosy, but I babied it around for eleven months getting acquainted while I gathered all the goodies for a rebuild. Were it mine, I'd see what it has to say and if nothing throws up a flag visually or audibly, I'd run it around at least a little. If it dumps oil out the front, back or tailpipe or rattles and bangs like two skeletons screwing on a tin roof barn, go for the rebuild. An oil pressure gage, even rigged up temporarily would help get a better read on condition.

  • Like 2
  • Haha 1
Link to post
3 hours ago, Rusty Dawg said:

The throttle was not wide open when I ran the test.  I disconnected the coil wire and turned it over 4 revolutions per cylinder.  I have spark at the spark plug, so once I place some engine oil in each cylinder I will try to get her going.  A local import mechanic told me to do the same thing and pour a little oil in each cylinder and try to start it.  Also, he told me that I should've have done closer to 10 revolutions per cylinder for my test.  Since it's been over 8 years since it ran, he said that I might be just fine once I run it a while🤞

I just pressure tested my J15 and you def need more than 4 revolutions. I put the gauge on the rocker cover so I could see when the needle stopped moving. Also do it with the throttle open just to see--it may or may not help but worth a try. 

 

My J15 with a new head gasket registered from 151-158 psi.

  • Like 2
Link to post

Good evening,

 

I am right on the cusp of starting this engine, but I need to know how to get it in neutral.  It wants to crank over, but it's in gear.  I have the rear brakes off right now with the back end on jack stands, so I can't just roll it to see if in neutral.  I have my slave cylinder off since I am in the process of replacing it.....the clutch pedal went to the floor.  Anyhow, can someone please direct me on the transmission sequence to find neutral?

 

My wife asked me today what I wanted for Valentine's and I told her that I just wanted for my truck to run.  Anything beyond that would be icing on the cake.  I'm must be getting old😂

  • Like 1
Link to post

 

 

 After you select what you think is neutral try to turn the driveshaft by hand if it won't turn, try again till you can spin it. It will only spin in the neutral position.

  • Like 3
Link to post

She's alive!!!  After finally getting fuel to the carburetor thru the new fuel lines she seems to run pretty nice.  Seems as though I have some wires crossed since the tank is almost full but shows empty and the temp gauge started above 212 and moved downwards.  Interesting that I was able to find "neutral" per datzenmike's suggestion, but when I got her started the drive line spun.  Oil gauge, if working properly, showed 60psi at idle.  I will try to insert a short video of her running on another posting.

IMG_2635.jpg

IMG_2636.jpg

  • Like 3
Link to post

Is this a positive ground??????

 

 

If accurate 60 PSI oil is very good.

 

Does tail pipe smoke? Does it puff on restart after sitting 20 minutes??

 

Driveshaft will spin from oil friction. Moving parts move oil that transfers motion to non moving parts. Like an electric fan blowing on another fan and spinning it.

  • Like 1
Link to post

Electrical stuff is not my strong suit, so I am not certain.  Other than changing bulbs, I did not do any type of wiring on this truck since acquiring it last March.  How do I confirm whether it's positive ground?

  • Like 1
Link to post

Love it love it! Nice work getting it fired up it sounds good!

 

Your temp gauge might actually be correct, on 320s the gauge rests in the off position buried all the up in the H. Then when you turn the key it drops down. Also if you've got a working thermostat you'll see the needle rise then fall when the thermostat opens. 

 

Nice work can't wait to see it on the road. 

  • Like 1
Link to post

Seems backwards, but ok.  I'll go with the temp starting higher and dropping down if it wasn't for the fact that the fuel gauge shows empty.  Why is this?  The truck has a generator in it and an antenna, but no radio although I believe one was mounted under the dash.

 

The truck initially smoked due to adding oil thru the spark plugs, but it has mostly gone away.  I only ran it for 3-4 minutes since I wasn't sure how to deal with the temp gauge.

 

I like the shift pattern written on the dash.  It would come in handy for me for sure.

Edited by Rusty Dawg
  • Like 1
Link to post

The generator will need to be polarized for negative ground if it hasn't been done.

If its charging it was probably done.

One side of the antenna is a direct connection to the body if the battery is reversed it may be a short unless the radio has a polarity switch, no radio no problem.

I had seen a thread somewhere that was about changing earlier Datsuns but cant find it, a good search may bring it up.

 

For British cars but there is a video on how to polarize the generator

https://mossmotors.smartsupportapp.com/articles/82-Converting-to-Negative-Ground

Edited by Ooph!
  • Like 1
  • Thanks 1
Link to post
14 hours ago, Rusty Dawg said:

Seems backwards, but ok.  I'll go with the temp starting higher and dropping down if it wasn't for the fact that the fuel gauge shows empty.  Why is this?  The truck has a generator in it and an antenna, but no radio although I believe one was mounted under the dash.

 

The truck initially smoked due to adding oil thru the spark plugs, but it has mostly gone away.  I only ran it for 3-4 minutes since I wasn't sure how to deal with the temp gauge.

 

I like the shift pattern written on the dash.  It would come in handy for me for sure.

It is strange how the gauges work I don't understand either. Fuel rests in the off position at empty and goes up when keyed on. Temp rests at the top in H and drops when keyed on. Maybe it's safer having baseline worst case scenario rather than a gauge breaking and thinking you have a full tank of gas and your car is always running cool? 

Link to post

Running out of gas is easily fixed. A temp gauge that starts at cold (and may be broken) doesn't read and you may over heat before you figure it out..

  • Like 2
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.