Jump to content

L16 first start advice?


Recommended Posts

I took Mike's advice and filled my cooling system with CLR two weeks ago and am still running that way.  It cleaned the rust and scale out.  I will purge the system Sunday and refill with an antifreeze mix when I put the tow hitch on. I learned very quickly that Mike and Charlie and others on this site have the info and experience to save us dummies from fates worse than broken skin and flat wallets.

  • Like 1
Link to post
  • Replies 28
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

4 hours ago, jagman said:

I took Mike's advice and filled my cooling system with CLR two weeks ago and am still running that way.  It cleaned the rust and scale out.  I will purge the system Sunday and refill with an antifreeze mix when I put the tow hitch on. I learned very quickly that Mike and Charlie and others on this site have the info and experience to save us dummies from fates worse than broken skin and flat wallets.

 

For sure. The help on here has been invaluable countless times so far. So you're just running water and CLR right now? Or did you add it to your coolant? 

Edited by Negative Ghostrider
Link to post
4 hours ago, datzenmike said:

That's different. If the top rad hose is hot then coolant is flowing, though perhaps slowly.

 

Air can't block a rad it will bubble to the top and leave a space you can top up. Take the rad cap off and drain a half gallon out of the rad so the top of the tubes are exposed. Are they clean? or crusty with hard water scale? What I did was remove the rad and place front down with rad cap on and fill with a bottle of CLR which will dissolve hard water scale. Give it over night and rinse the next day. Good for drains with copper pipes abd solder so safe to use on brass rad with solder seams. I was busy and left mine for 3 full days with no ill effect.

 

31082-clr__39362.1597172917.jpg?c=2

 

I didn't notice any scale or anything inside when I removed it or when I was filling it. Looked very clean, actually. Same with the hoses. There were definitely some signs of rust in the passages on the head and block, but no evidence of heavy buildup or blockage though. I was planning on doing a full system flush soon anyway but under the circumstances I obviously need to resolve the issue at hand first. Still, it worked fine before. That's why I'm confused. The rad was off for months so maybe some crap dried out and crusted up in there while it sat. Thermostat and gasket are like 15 bucks so I may as well just toss that in, and I'll soak the rad with CLR if that doesn't do the trick. Jagman says he's flushing the system with CLR as well. Do you recommend that over some off the shelf radiator flush stuff? Thanks. 

Edited by Negative Ghostrider
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.