Jump to content

racing engine , help ?


butter fingers

Recommended Posts

hello guys , last week it reared its head then it went away . last night the problem came back ! the engine is pegged and i got it home somehow . this morning i started it and had to turn it off right away because off the revs . it doesn't  seem like the cable is stuck , what can i do ? butter fingers 

Link to post
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Is the cable jammed or is something else holding it open?

I had this kid named Justin call me one day, his 1985 Nissan 720 truck was in a parking lot very close to me with what appeared to be a revving issue, he could not drive it that way, I got my flashlight and tools and headed over there, he showed me it rev all by itself when he started it, I don't remember for sure what carb it had at that time but I think it was stock as it was using the stock air filter housing, so I checked the linkage out and it was fine, this guy drove it like he stole it every time he drove it(like me when I was a kid), I next took the top of the air filter housing off and looked down the carb, the primary looked fine, but the secondary looked like it was slightly open, when I looked really close there was something between the butterfly valve and the side of the carb housing holding it open, I used 2 screw drivers, one to hold the crap in place and the other to open the butter fly valve, once I got it out the engine ran fine, it appeared to be hard insulation or the like from the air filter housing itself, somehow it got sucked into the carb and got jammed in there.

He later put a Weber on it, lowered as low as he could get it, then on a rainy day he wrecked it by rear ending someone, it destroyed the front of that truck.

 

DSCN3788.thumb.JPG.5ca56b6af0f514694346ffdaed471a97.JPG

 

I then built this with that frame/chassis/engine/wiring harness.

DSCN4063.thumb.JPG.0408a347ab9221e458346e12388812d4.JPG

 

Link to post

Wayno , you do great work ! my problem  got resolved for now . i could find nothing wrong except a bare wire was exposed to the 6 wire plug  (feed back carb ) could that wire grounding out been my problem ? after 2 times having the reving issue i am hoping it does not return . PS , yesterday i had to check out a full-on ST that is for sale 2 miles from my home . a 4x4 like my truck . the guy gave me the key and i surveyed the truck . i handed him back the key after 10 minutes and thanked him for letting me look at it . He was dumb founded that i never even bothered to start it ! in short , a real toilet ! LOL 

  • Like 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.