Jump to content
Spiritspeaks

My engine siezed

Recommended Posts

My engine siezed after I changed the head gasket. Got it put back together, timed it, fired it up, it ran great for about a minute, then siezed. What did I mess up? Am I screwed? This an L20B.

Share this post


Link to post

What makes you think it's seized????

 

Were you driving it or just idle?

Does it have oil in it?

Was the oil light on or off?

Share this post


Link to post

Are you sure it seized ? pull the plugs and try to spin it.Maybe you have water in the cylinders ? 

Share this post


Link to post

It won't spin with all the plugs removed. It has fresh oil in it. It ran for 45 seconds to 1 minute (really well). Then made what sounded like a dry cylinder squeal, I immediately switched off the ignition. Attempted to restart it, and got the click sound of a dead battery. Battery is new and fully charged. Then, I attemped to spin it at the crank with a ratchet and no turning it there. So, I pulled all the plugs and tried again, forward and backward. No luck. She is stuck.

Share this post


Link to post

No. Correct gasket. If, by chance, it had a blocked oil passage, wouldn't it run more than a minute? If it is ruined, what would be options for a replacement engine that would bolt up to my manual 4 speed? It is a 4x4.

Share this post


Link to post

Maybe the cam seized in the cam towers. Did you have them off the head? You could have inadvertently plugged the head oil passage when scraping the old head gasket off.

 

Did you remove the oil pump? Did you watch for oil pressure when you fired it back up? Did it have oil in it?

 

Try removing the cam bolt and sprocket. Can you rotate the cam by itself?

 

 

Edited by Stoffregen Motorsports

Share this post


Link to post

You should be able to look under the valve cover and see if the cam is covered in oil or not....  that would tell you if the oil passage is blocked or not....

 

How about the tensioner?

Did you block the chain and tensioner with a wedge?

 

I've seen these engines run with a popped tensioner not sure if it would be enough to stop things from rotating....

Share this post


Link to post

you did the head gasket in the truck using a timming chain wedge or you remove the front cover?

if you removed the front cover that means maybe you drained the oil out o the oil pump.??????????

 

go back to last 2 responses

 

 

find another L20 is the Ezest option

as I would Like a 720 with a L20 motor in it (4x4)

Share this post


Link to post
On 12/2/2019 at 4:37 PM, datzenmike said:

 

Does it have oil in it?

Was the oil light on or off?

 

Try it with the clutch pedal held down? This eliminates a seized transmission.

Cam might seize but there is enough chain slack that the crank would wiggle slightly. Does it?

 

Pull valve cover off and look.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.