Jump to content

Finally got a 510


grannyknot

Recommended Posts

  • Replies 80
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

Just noticed all the throttle cable talk. I am running an S13 cable on both my 510 and 620, the 510 is a bit different since its running carbs... but the 620 should be pretty similar. The biggest issue you are going to run into running it straight back to the firewall, along the FW and then into the cabin is those are very tight bends which aren't going to allow the cable to slide smoothly... particularly the bend into the cabin.

Here is my 510 set up -

20180413_172922

 

Here is my 620 set up - 

 

20191006_181114

 

The 510 cable is noticeably stiffer then the 620 and they are using the same cable - I think the biggest difference is the tight ben coming out of the firewall that the 510 cable has, and less so the big u bend that the 510 cable has.  I could probably benefit from a longer cable on the 510 to create a bigger more swooping bend out of the firewall. With the position of the carb linkage its always going to have to cross the engine I think....

With that said... I would be interested in a longer cable for the 620 as well which would allow the cable to sit fully in front of the engine instead of against the oil cap. 

You may want to consider running it straight out the firewall and across and up the front either way for a straighter run.

 

i can take more photos this afternoon/evening if you want anything specific. 

Link to post
8 hours ago, demo243 said:

You may want to consider running it straight out the firewall and across and up the front either way for a straighter run.

That's a good idea, hadn't thought about that.  With a bit of creative flange fabrication I might be able to get the cable to loop under the distributor before heading to the firewall.

Thanks

  • Like 1
Link to post
  • 1 month later...

I got the front suspension dropped and started disassembly for sand blasting, these are the front springs, how the hell can anyone mash up a set of springs like this?

Also tore down the steering box and waiting for new seals to arrive and hardware to come back from the platters.

1572823899_IMG_0062(1024x768).thumb.jpg.b16fbf6f68b56bd935f727cde6f1325c.jpg77360004_IMG_0081(1024x768).thumb.jpg.1f64dc3d81f5de7f210d7f5ba7e36b74.jpg1265961768_IMG_0082(1024x768).thumb.jpg.336b145b9a3d94b358b78e1820ab41b8.jpg1084754526_IMG_0091(1024x768).thumb.jpg.cd91fd9ac7638250c1cb1caec1a2f5fb.jpg

Link to post

Jeez, those springs are a level of hackery I've not seen firsthand before. How much did that blasting cost you, out of curiosity?

Sounds like a fun build, old pics are broken sadly.

Link to post
2 hours ago, Noll said:

Jeez, those springs are a level of hackery I've not seen firsthand before. How much did that blasting cost you, out of curiosity?

Sounds like a fun build, old pics are broken sadly.

I wonder what happened to all my pics, I'll have to see if I can get them back up.

The sand blasting for everything in the pics was $150 cash from a place in Bolton.

  • Like 1
Link to post
22 minutes ago, grannyknot said:

I wonder what happened to all my pics, I'll have to see if I can get them back up.

The sand blasting for everything in the pics was $150 cash from a place in Bolton.

 

Not bad at all, gives me a good ballpark for if I want to get any stuff blasted locally (there's a guy maybe less than 2km from me that does it which is sweet).

Link to post
  • 1 month later...

I've been busy over the summer prepping parts and getting things ready for an easy install next spring.  I've tried to repair dash cracks on 240z's before but they never look right to me so I covered this one trying to make it look like it belongs... but we all know what it is hiding.

 

IMG_0172 (1024x768).jpg

IMG_0182 (1024x768).jpg

IMG_0184 (1024x768).jpg

IMG_0216 (1024x768).jpg

IMG_0217 (1024x768).jpg

IMG_0218 (1024x768).jpg

IMG_0221 (1024x768).jpg

IMG_0222 (1024x768).jpg

  • Like 1
Link to post
  • 3 weeks later...

I got the engine and trans in today, still have to modify the engine mount flanges.  I read somewhere that I could use the 240sx engine isolaters so I ordered new ones with all the other stuff. Looking at them now I guess I could use them but they are going to look kinda clunky. 

I guess this swap has been done many times, if anyone sees something I'm doing ass backwards please feel free to set me straight.

The second pic is with the weight of the engine/trans being supported by the car, I think once all the other weight is added the car might just sit right where I want it to but I guess that is one of the last adjustments.

The tires are shot but I found a set of Western Cyclone II's  14"x6" I've loved them since I was a kid, looking forward to cleaning them up.

 

 

IMG_0313 (1024x768).jpg

IMG_0316 (1024x768).jpg

IMG_0322 (1024x768).jpg

IMG_0323 (1024x768).jpg

IMG_0320 (1024x768).jpg

IMG_0321 (1024x768).jpg

Edited by grannyknot
Link to post
4 hours ago, grannyknot said:

I got the engine and trans in today, still have to modify the engine mount flanges.  I read somewhere that I could use the 240sx engine isolaters so I ordered new ones with all the other stuff. Looking at them now I guess I could use them but they are going to look kinda clunky. 

I guess this swap has been done many times, if anyone sees something I'm doing ass backwards please feel free to set me straight.

 

 

Most people seem to use the stock L series engine mounts in the lower holes, but they bind a bit... I had trouble with that and ultimately couldn't use them. I went with McKinney mounts, but wasn't super impressed with them, and I dont know if they are even operational any more... There is a post on the 510Realm about using 1/2" spacers between the block and the iron mounts to align the iron mounts with the stock L series isolators--- I'll see about digging it up... but it looked good and I have been planning on trying that at some point. 

Side note - I also had my iron mounts off the block tweaked to set the engine back another ~1" in the engine bay. Puts it very close to the firewall... but should help with the weight dist. 

Needs more LOW! But definitely missing alot of weight so who knows where it will end up

 

Looking good!

Edited by demo243
  • Like 1
Link to post
12 hours ago, 510revisited said:

I would venture to say your springs got hacked by the old fire ax...

They were pretty bad, all I can think is that they were cut so short that every time the car went over a bump there was free air between the top of the spring and the shock tower so the car was in free fall until it slammed the spring down, must have been a brutal ride.

 

8 hours ago, demo243 said:

Most people seem to use the stock L series engine mounts in the lower holes, but they bind a bit

Thanks, I'll order a set and play with them.

Link to post
46 minutes ago, grannyknot said:

They were pretty bad, all I can think is that they were cut so short that every time the car went over a bump there was free air between the top of the spring and the shock tower so the car was in free fall until it slammed the spring down, must have been a brutal ride.

 

Thanks, I'll order a set and play with them.

Here’s one of threads about using the spacer

 

https://www.the510realm.com/viewtopic.php?f=3&t=29668&start=45

Bump back a page for some more info on fitment--- its for an SR but should be very similar to the KA as I had the same issues with the KA, I believe their end mount points are the same.

https://www.the510realm.com/viewtopic.php?f=3&p=268172

Edited by demo243
  • Like 1
Link to post
  • 4 months later...

I have accomplished a few things since the last post,  figured out the engine mount situation and built the trans mount, the driveline angles are done and the driveshaft shortened.  I haven't actually started the engine yet but I think everything is wired correctly with regards to the Can-am box, the Datsun wiring harness was taken apart, cleaned repaired where necessary and re-wrapped.

 

The transmission console has been roughed in, installed the doors and panels and got the gaps looking pretty good except for the hood, need to spend more time on the D/S hood gap.

Picked up some sticky looking Falkens 195/60/14, hope they are not too big.  I lengthened the brake pedal arm to gain some better leverage, I've never tried it before so interested to see what the results are, easy enough to re-instal the stock pedal if I need to.

 

The car is up on the rotisserie now so everything just got a lot easier to access, the rear quarter panels arrived and are next on the list after I finish the new gas and brake lines, these guys, http://fedhillusa.com/

make the best Cunifer gas & brake lines I've ever used, the lines are thick walled so really resist kinking. The gas lines need a tube bender but the brake lines can pretty much be bent by hand, a rub with 0000 steel wool brings them up to a warm shiny glow.

1467300569_IMG_0375(1024x768).thumb.jpg.593d365f6750883f58a49a93024ea147.jpg1371478616_IMG_0389(1024x768).thumb.jpg.ffb2351382cbe0235749513d81a6fab7.jpg779290120_IMG_0360(1024x768).thumb.jpg.8b5498b98282c7d0ad067ffbbb884b3e.jpg2132211204_IMG_0612(1024x768).thumb.jpg.9b3f6ac0f85ce0a7e3558d7006810079.jpg1353448516_IMG_0578(1024x768).thumb.jpg.1d353d1c20c5be4f39aac45fbadd22a7.jpg1120033101_IMG_0681(1024x768).thumb.jpg.5d3b7af47d8f286ee154f3b857a5f66a.jpg981297513_IMG_0707(1024x768).thumb.jpg.35a21fa472373078b8230088df124ca8.jpg315473232_IMG_0708(1024x768).thumb.jpg.08a3cbdfc5f07af8293b7e4f2dcd68a5.jpg

 

 

 

  • Like 2
Link to post

The brake & gas lines are done, I widened the exhaust pipe hole in the rear cross member and the Ermish Racing exhaust pipes arrived as well as the DBX Flowmaster muffler.  I bought the DBX separately because I've used them before and I think they have richer sound than the Super HP that Ermish sells.

I was ordering a few more rubber parts from http://www.new-datsun-parts.com/datsun-510-parts.html

that I missed on my first order and notice the Roll Center Adjusters/ Bump Steer Spacers they sell, they're $35 per set!

That's a 1/3rd the price of everyone else, I ordered a set and they are quality pieces, 10.9 grade bolts and they fit perfectly.

 

So there is no more avoiding it, time to put the mask and ear protection on and start making a mess.

 

 

 

IMG_0727 (1024x768).jpg

IMG_0729 (1024x768).jpg

IMG_0735 (1024x768).jpg

IMG_0738 (1024x768).jpg

IMG_0732 (1024x768).jpg

IMG_0731 (1024x768).jpg

Link to post
  • 2 weeks later...

After replacing the bearings and seals in the LSD R160 Diff I adjusted it to the best of my ability then took it up a Diff shop I have used before for them to do the pre-load and backlash adjustments. They got the wipe pattern looking great.

 

I'm not sure why the floor pan rails aren't produced by anyone yet, they take a lot of abuse.  Luckily mine were in pretty good shape with just some rust at the tail end.  I got the end pieces finished today and welded up.

1113031776_IMG_0740(1024x768).thumb.jpg.bfe655f08630ca1c236d14849327dd3e.jpg1612607593_IMG_0755(1024x768).thumb.jpg.fe1e069a0cd19be7f677103fc90a66c6.jpg1838103738_IMG_0765(1024x768).thumb.jpg.2df02951f3ccc23c88ce22defb217f6d.jpg266904010_IMG_0767(1024x768).thumb.jpg.f2c1fb0a5f2c98ffab5e1797377d400e.jpg1442641005_IMG_0768(1024x768).thumb.jpg.0b0b8b592e40deeaa1942932755bcc92.jpg

 

  • Like 1
Link to post
  • 2 months later...

Yikes, it has been a while.  here's what has been going on since the last update. I got the shell stripped down to the metal, replaced the quarter panels, refinished the Cyclone II wheels and got the new tires mounted, 2 coats of epoxy primmer on everything and just finished laying on 2 coats of high build dark grey primer today, so far everything is looking pretty smooth but will start first thing tomorrow with guide coat and find just how smooth.  Would kill for a bigger shop right about now.

 

 

IMG_0864 (1024x768).jpg

IMG_0868 (1024x768).jpg

IMG_0884 (1024x768).jpg

IMG_0973 (1024x768).jpg

IMG_0976 (1024x768).jpg

IMG_0996 (1024x768).jpg

IMG_1003 (1024x768).jpg

IMG_1002 (1024x768).jpg

  • Like 3
Link to post
  • 2 weeks later...

Nice progress on the car. I have a soft spot for those wheels because my first 510 had them. I painted the area between the ribs body color, it was an 80's thing.

Link to post

looking good buddy!  Nice work and glad to see you're taking the time to do her right.

Link to post
5 hours ago, Z23T said:

Nice progress on the car. I have a soft spot for those wheels because my first 510 had them. I painted the area between the ribs body color, it was an 80's thing.

I have always loved the Cyclones,Turbines wheels, when I was a kid in the 70's they were always seen as a notch above the other Mags, at least in neighborhood.

4 hours ago, 4perrev said:

looking good buddy!  Nice work and glad to see you're taking the time to do her right.

Thanks, I just finished 600 grit today so I can finally start prepping for paint, the panels are starting to shine a bit from certain angles.

 

IMG_1030 (1024x768).jpg

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.