Jump to content
CS310

72 510 Park/Tail fuse terminal getting hot

Recommended Posts

Hey guys, I need some help with my 72 510. The park/tail fuse terminal gets hot when I turn on the parking lights. Only the outside terminal. This is what I’ve tried so far. 

 

Replaced the fuse 

Cleaned the fuse box terminals

Swapped out the fuse box

Swapped out the light switch

Unplugged all the rear lights (This seemed to help. The terminal stayed somewhat cool. Maybe a fuzz hotter.)

 

The wiring on this car was a mess when I bought it. I’ve been slowly cleaning it up.

 

Any suggestions would be appreciated. 

 

Share this post


Link to post

Check the grounds out at the lights. Make sure they are clean with good connections.

Share this post


Link to post

Heat is caused by resistance to current flow. Replacing everything else can only increase the current flow and make it hotter. This is why it was cooler after disconnecting some of the lamps. You have some resistance where the fuse contacts the clips that hold it. Heat will also take the temper or springiness out of the clips, the clips don't grip the fuse as well and the contact is worse and it makes more heat. A vicious circle. If the clips are not heat damaged and have good grip try the following.

 

I imagine the clips are brass or some copper alloy. My 620 box was tarnished and looked like an old brown penny. I removed it, washed in soapy water to remove any oil residue and filled a suitable size container with Real Lemon, lemon juice and about 1/4 cup of table salt dunked it in and brushed it with an old tooth brush then soaked it over night. Rinse with tap water and shake dry.

 

6XXHZRx.jpg

 

 

If the clip is damaged try wiring in an inline fuse just for the tail lights. Be sure the fuse is the correct amperage and the wire as heavy a gauge as possible. New ones use the more common bayonet fuses.

61qUHiIUnIL._SX425_PIbundle-5,TopRight,0

  • Like 2

Share this post


Link to post

I’ll check the grounds and try cleaning the fuse box. 

 

I’ve used this same mixture to clean my hands after handling mahogany wood. Worked awesome. 

 

Thanks guys. 

Share this post


Link to post

clean the  white connector connections that plugs in the fuse box if you havent done this already.

 

of coarse it going to run coolor if the rear lamps are not drawing anypower.

Edited by banzai510(hainz)
  • Like 1

Share this post


Link to post

I wanted to give an update on my issue. This is what I did. 

 

1. Checked all the grounds for the lights. No problem here. 

2. Cleaned the white wire connector coming out of the fuse box. This looked good before cleaning but wanted to be sure. 

3. Cleaned and soaked the fuse box in lemon juice and salt. This worked amazing. Also used a brush with a dremel on low speed to do a final cleaning. 

 

The result was good. The park/tail fuse was much cooler. Still a fuzz warm. No where near what it was. 

 

Then I discovered a mistake on my part. When I replaced the park/brake bulb receptacles, I switched the park and brake wires. So when I would turn on the parking lights, the brighter 1/2 of the bulb would light up, using more power.  I switched this and the fuse box is nice and cool..

 

i appreciate all the suggestions and advice. 

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.