Jump to content
Sign in to follow this  
CharlieMurphy

Z20 with a Weber 32/36, vac problems

Recommended Posts

Has anyone done this?  I am having a hard time finding anything to help.  Pulled a stupid move cause I thought I had a 2.4 but the plate under the hood says Z20.  I am so lost right now with most of this since I’ve been looking at a 2.4 swap. There’s minor differences that I’m missing.  Any help is valuable and I have swallowed my pride as a man.

 

 

Share this post


Link to post

What's it doing? Because its idling just fine to me.

 

47381948_2293122344253012_38875294239429

This pipe from the exhaust manifold uses exhaust vacuum pulses to pull air from the air cleaner through a one way reed valve. This added oxygen helps the catalytic converter to burn off any un-burnt gas. You could adapt the air cleaner to fit the weber or just remove the pipe and put a metric pipe plug in the manifold. Not that necessary, up to you

 

There were Z20 and Z24 gas engines on the '85. To be sure look between the #2 and #3 exhaust spark plugs down on the top edge of the block...

 

Q9xYbRS.jpg

 

Also look at the engine plate in the inner pass side under the hood hinge...

 

3op9wC2.jpg

 

Take a look at the MODEL line. (3rd one down). A Z20 equipped will start KFL 720...... A Z24 will start KNL 720..... (K is for the extended cab)

.

Share this post


Link to post

Update!  As of now, she's running how I would want her to be running.  There's more vac hoses that I need to replace just because I don't like the old stock ones as they are older.  Plugged the vacuum advance port along with the pipe from the exhaust manifold.  I am in the process of getting new headers so as to completely delete the silver pipe.  I tried my hardest to get that thing out but it feels like it's seized up in there.  I am still searching for a picture of someones engine so I can try to copy it.  I did notice on the Z24 there were 2 canisters on the right hand side, my truck only has 1.  DatzenMike, thanks for your help.

Share this post


Link to post

Cut the pipe off 2" long and crush with vice-grips, then roll it up to seal it. A header is a waste of time and money, you'll be sorry you did it.

 

Definitely connect the vacuum advance to the distributor for better part throttle running and mileage. The vacuum advance fitting on the carburetor is the one closest to the front.

 

 

Right hand side is how you would see if from the driver's seat. Right side is the passenger side. The emissions canister is on the left or driver's side bolted to the rad support. The only two things I can think of are the ignition coils.

  • Like 1

Share this post


Link to post

The vacuum advanced port isn’t there.  It’s missing so I plugged it.  The canister is on the left hand side but like I said, I only have one.  As of now, this truck is running pretty good.  I’m still gonna go through and replace lines.  For the advanced port if it’s missing, is there a way to replace it?

Share this post


Link to post

The port will be there, if you mean the little pipe the hose slips onto just pull out the one for the EGR and use it. Vacuum advance is crucial to good part throttle running and mileage.... well worth the effort.

 

The only 'canisters' on the right side I can think of are the vacuum switches for the fuel shut off and the single plug operation. They are on the inner fender, small and have wires going to them.

Share this post


Link to post

Let me rephrase part of my last post, forgive me I am nice and sick from all the happy times of this year.  The right side has a single canister, with the line going under the coolant reservoir.  Is this where I hook into from the vacuum advance fitting?  I will pull off the old port and try to make it work.  

 

Mike, you sir are one in a million.

Share this post


Link to post

The ignition vacuum advance does two jobs. One it advances the ignition timing in the distributor under light loads and two, it signals the charcoal canister to purge it's vapors  through a separate hose into the intake.

Share this post


Link to post

Ok, so what is the hose going under the coolant reservoir?  Tomorrow I am going to go back for round 2 of doing the vac hoses again.  Is the z20 even a decent motor?  Would it be more worth while to get a Z24?  Or, should I just start finding replacement parts here and there and gradually making this motor newish?  Or, do you think going older to a 620 would be more simple?  I am no mechanic by any means, but i can figure stuff out the more I play with it.

Share this post


Link to post

How do I take off the advance port from the old carb?  It looks like all I can do is cut it.  Is there another way?

Share this post


Link to post
2 hours ago, CharlieMurphy said:

Ok, so what is the hose going under the coolant reservoir?  Tomorrow I am going to go back for round 2 of doing the vac hoses again.  Is the z20 even a decent motor?  Would it be more worth while to get a Z24?  Or, should I just start finding replacement parts here and there and gradually making this motor newish?  Or, do you think going older to a 620 would be more simple?  I am no mechanic by any means, but i can figure stuff out the more I play with it.

 

The hose under the reservoir... my guess is it's the vent from the gas tank. Fumes expelled from the tank are stored in the charcoal canister.

 

What you have is the Mileage option 720. The Z20 is a high compression engine with 5 speed and very low 3.364 differential gears. Everything is 'geared' towards good economy.

 

s-l1600.jpg

 

The vacuum advance port should be the one pictures at the very bottom right.

,

Share this post


Link to post

I see it but, how do I take it off?  When I do install it, where does it connect to?  Vacuum systems are quite confusing.

Share this post


Link to post

If the little pipe is sticking out leave it. Usually a hose goes from it to one of those hard lines down over the front of the engine to near the distributor with a hose to the distributor and the charcoal canister.

Share this post


Link to post

That's where I am running into problems, there is not brass piece on the weber carb.  Can I cut this piece out and put it in with JB weld?

Share this post


Link to post

You have a Weber?

 

Well it should also have a vacuum advance port already on it. I'm not familiar with where it's located.

Share this post


Link to post

it is on the bottom left hand side.  It is missing.  The diagram/manual for the carb said it is optional.  

Share this post


Link to post

I wouldn't have thought so.... all engines run vacuum advance.

Share this post


Link to post

Crazy right?  Ok, tomorrow I will start posting some better pics but, if you look at the 3rd pic, that is where the advanced port should be.  I can hear it hissing but I plugged it.  I still need to adjust some things with it but the vacuum system is what's getting me under the hood.  So, new pics tomorrow.

Share this post


Link to post

I assume it's a 32/36 Weber?

 

dgxv_parts_labled.gif

Share this post


Link to post

So the hole is there but no pipe?

Share this post


Link to post

Well you'll have to make something work here.

 

This is ported vacuum so not directly connected to the intake.The port is above the edge of the throttle plate but as soon as the throttle is opened vacuum is applied to the port. This is so there is no advance at idle but vacuum advance above it. This is strictly an emissions measure for idling engines. All carbs since the late 60s use this method.

Share this post


Link to post

Well, I am located in Washington and this vehicle doesn't have to pass emissions.  All I am trying to do here is clean up the hoses and make this look presentable like me when I was trying to take a girl on a date when I was 16.

Share this post


Link to post
On 12/7/2018 at 8:16 AM, datzenmike said:

Well you'll have to make something work here.

 

This is ported vacuum so not directly connected to the intake.The port is above the edge of the throttle plate but as soon as the throttle is opened vacuum is applied to the port. This is so there is no advance at idle but vacuum advance above it. This is strictly an emissions measure for idling engines. All carbs since the late 60s use this method.

 

The vacuum advance isn't about emissions. The only relevant part is NOT having it at idle. You NEED vacuum advance for all part throttle performance and economy. Try your best to rig something up when you can.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use.