Jump to content
slim_jimmy7

Headlights High Beams Always On

Recommended Posts

I wasn’t too worried about my headlights because they work. However, I got pulled over the other day because my high beams were always on. I cannot get them off, everything looked ok on the column switch. I cleaned up the contacts on the column. I did get a new headlight relay because the old one burnt up, it’s a 72, the replacement relay is one of those with the separate plastic connector. The dash does indicate that the brights are on.

 

I unplug the outside lights and inside ones still work, all my indicator lights work as do my blinkers. What am I missing, or what should I check?

Share this post


Link to post

Check all your fuses. This past Canby, a friend couldnt get his high beams to turn off. One of the fuses were bad. Weird!

 

Share this post


Link to post

To have the low beams working you MUST have the parking lights working. The hi/low beam relay has only 2 choices hi or low. When the relay is OFF the high beams are selected. To energize the relay, power is provided by the parking lights. Without parking lights the relay can only be OFF no matter what the switch is set at.

 

If you have parking lights, find the headlight relay and check for power on the Green/Blue wire. This is the power from the parking light circuit. Try unplugging and plugging back in to clean the contacts. If no power find out why.

 

If there is power, ground the Black/Red wire. This is the hi/low switch wire and should be grounded when the low beams are selected. If the low beams come on and high beams off then the problem is the switch on the steering column. If nothing happens then the relay is faulty.

Share this post


Link to post

That is really helpful actually, both of you. When I got the vehicle the parking lights were not even wired. I may have wired one of the parking lights wrong (there were extra wires in the mix), so I will check both of those.

Share this post


Link to post

Is this a 510?  Are you running yellow Mercedes fog lights in place of your highbeams? I think there has been a documented concern in the past where the metal headlight housings from these Mercedes foglamps can create a ground path and cause the lights to stay on all the time.

 

this is not likely your concern but it is a place to look.

  • Like 1

Share this post


Link to post

Not Mercedes but I did have that problem with another brand. I had to insulate the outer metal case from the headlight buckets for them to shut off.

Share this post


Link to post

As an update, checked over everything. Turns out the relay is not working properly, going to order another one and see what happens

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.