Jump to content

A 521 in Massachusetts


Crashtd420

Recommended Posts

  • Replies 3.9k
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

I have done everything I can possibly do....

Just made sure all the driveshaft connections and center bearing mount were all tight...

I left my dash cluster exposed since the other led bulbs will be here Wednesday.... 

I also made an adjustment to the blinker switch arm.... it was very close to the steering wheel with the high beams on due to the fact I went with a flatter style steering wheel ...

I had one of those brake line bending tools that does 3 different sizes... I was able to use the 1/4 inch part to put a slight bend in the arm ....

So now I'm just waiting for paint to dry... should be able to do the second coat in a couple hours.... 

  • Like 2
Link to post

Seals were waiting for me when I got home....

Absolutely a perfect fit.... 

I'll probably post the info about both seals I found in the parts thread later when I have some time....

  • Like 1
Link to post

I managed to get the watts link bar secured to the axle and the assembly under the truck.... 

I have the 3 bars attached with just the nuts hand tight.... I assume I should torque them with the truck on the ground....

 

20210329_173913.jpg

20210329_173920.jpg

  • Like 3
Link to post

I had ordered new axle shims, still hoping they are the same... anyhow I will soon see, they actually shipped all the ones I asked for.... I half expected some of the order to get canceled...

 

Also while assembling the suspension I wasn't happy with the length of 4 of the 1/2-13 bolts supplied.

I added washers between some of the surfaces because I wanted to but they took up a little of the length... so they were barely able to engage the nylon portion of the nylon lock nut.... 

I have 4 new bolts slightly longer on the way to give me some piece of mind....

Hoping things arrive by Saturday....

  • Like 2
Link to post
1 hour ago, greenthumb said:

Looking good!

Interested to hear how the ride and handling are compared to the old system 

Trust me so am I.... datsun driving season is definitely back up here in Massachusetts and I'm itching....

I'm hoping it's a worth while up grade because it was a lot of work...

 

I am almost more excited to try the brakes, my drums were covered in gear oil from the axle, so I doubt they were actually helping stop the truck.... 

 

 

  • Like 1
Link to post

Well I'm back in the holding pattern again....

I installed the seals into the axle housing and put the bearings back in the hubs....

I was going to temporarily use the old shims to keep going, and while I was cleaning them up, I was wondering why? I remembered I got an email the new ones shipped....

Well they are going to be here tomorrow,  so work is done for the night.... 

I put the battery on the charger for good measure....

20210331_194025.jpg

  • Like 1
Link to post
Posted (edited)

Axle shims and the blue leds for the cluster arrived....

I was able to install the leds and cluster before I had to get my kid from school....

I'll get a pic later with it lit up and in the dark.... 

As for the shims they will fit, but I was very surprised to see they were already split....

 

20210401-153218.jpg

 

Since they are all like this I assume it's for a reason.... it is supposed to be like a drain for gear oil If the seal fails?

Also assuming split would be at the bottom if it is supposed to be a drain...

 

I may have gotten more than I actually ordered,  one package says quantity of 1 but I see 5 in the package....  

 

20210401-153202.jpg

 

I'll have to sort through them to see what I actually have... having some spares wont hurt if I have ever have to use the other 2 axles I have....

 

I'll post up the available shim number and size when I get a moment....

Edited by Crashtd420
  • Like 1
Link to post

I posted the shim info in the parts thread.... 

 

And I should have checked 1 more time before I put the cluster all back in the dash, damn high beam didn't light up, I swear it did the other night... oh well quick fix (hopefully)... here is the cluster in blue... sorry if the picture sucks....

20210401_200553.jpg

  • Like 2
Link to post

The split is so you can get them on and off w/o pulling the whole shaft out of the housing. The ones in my roadster practically disintegrated when I took them off. I just cut new ones out of brass shim stock. Had I known that these existed, I probably just would have bought some.

Edited by mainer311
  • Like 2
Link to post

I was able to sort the light issue while finding another....

 

High beam I need to clean the contact on the back of the cluster...

And then I checked everything else and now I have no right blinker....

Thankfully that was the bulb in the taillight housing  .... now eveything is ready electrically and dash is back together.....

Even grabbed some fresh gas to put back in the tank.....

  • Like 1
Link to post

Then I focused on the axles....

That was not fun....

It took me a few rounds of installing and removing the axles.....

I thought I was good but last night something was off.... the end play wasn't making sense....

So today I started over....  I double checked that the bearings were seated and I dont think the passenger side one was enough....

After I was able to use a straight edge and verniers to make sure both sides were the same.... now things looked better....

I managed to get the end play down to .002... tolerance was .0008-.0059

20210402_163252.jpg

  • Like 2
Link to post

And we have disc brakes....

I have everything hooked up now....

I think all I have left is to bleed the brakes, and tension the parking brake cables.....

Then get the wheels on, set the ride height and torque everything.....

20210403_121745.jpg

  • Like 3
Link to post
1 hour ago, Stoffregen Motorsports said:

#shortlist

Very short.... 

And of course i go to bleed the brakes and I have no brake fluid..

I guess I over looked that fact....

  • Like 2
Link to post

Truck is on all 4 wheels..... I was trying to set it to ride height but realized there is little to no weight in the back without a bed, so the springs are barely compressing..... 

 

20210403_160113.jpg

  • Like 2
Link to post
Posted (edited)

I did fire it up because I was dieing to hear it run.... i haven't heard that motor run since early December...

Fuel pump primed fairly easy, I have an override switch (generally turns on/off by an oil pressure switch), so a couple times with that and everything filled up nice and the truck came to life no problem....

But then I noticed the battery not charging till I hit the gas a little...

Never had that issue....

Oh well I'll keep an eye on that....

 

Thanks dp you jinxed me...

 

And then I checked my new fuel pressure gauge... nothing...

 

Check the gauge with a little bit of compressed air and the gauge moved. So the gauge isnt broken....

So I decided to adjust the fuel pressure regulator and see if the psi would come up and sure enough it did.....

Goes to show you dont buy a piece of crap gauge like i originally had.... i had adjusted my pressure down last summer because the gauge was reading high, my guess is I was barely supplying enough fuel to the carburetor... I'm really glad I bought a better gauge now...

 

 

 

Edited by Crashtd420
  • Like 1
Link to post
2 minutes ago, Steve240z said:

Yay!!!!   and congrats

Thanks.... still a little left to adjust and tighten but I should be ready to drive tomorrow.... I'll probably buzz it around town for a week as a shake down before I put it back into daily use..... 

  • Like 3
Link to post
22 hours ago, Crashtd420 said:

But then I noticed the battery not charging till I hit the gas a little...

Never had that issue....

Oh well I'll keep an eye on that....

 

Thanks dp you jinxed me...

 


image.gif.b8d116ddbcd95e7135ba4a9d31df9913.gif

  • Like 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.