Jump to content

KA24DET B310 BUILD UP


jesusno2

Recommended Posts

Great build Luke! So how does it run now? 

 

BTW, your turbo fins should NOT contact the housing! That is the first thing I check on tractors. Second is the bearing under the oil feed line. Make sure it floats when you rotate the shaft. It should NOT stay with the shaft or the housing. 

Link to post
  • Replies 382
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

  • 2 weeks later...
  • 1 month later...

Thinking i found the source of my Tstat housing leak that for some crazy reason never noticed and it was leaking so bad it took me awhile to figure out where it was coming from cause i had coolant everywhere

 

8CA75CC7-B267-44FB-8D6A-29ED0CD85921_zps

 

Also couldn't find a cooper flange gasket of the back of this turbo and im cheap and made my own flange.

 

D4C2214A-0FE4-4743-8571-7F5091CAF9B8_zps

  • Like 1
Link to post
  • 1 month later...

How is this running now? Are you happy with it? This deserves a craftsmanship award of some kind:)

#1 participation trophy?? 

Megasquirt issues. I do have a working clutch now still have a exhaust and oil leak. Might have brakes now haven't driven it again. The Megasquirt thing is super confusing to me, cause i don't speak the computer language. but if ya never dive into things you don't understand you'll never learn. I'm starting all over with a ka24de base tune. I think for some reason my current tune is having some kinda weird glitch. cause my timing gun and my ecu are reading 10 degrees different from one another and i can't figure out why. 

  • Like 1
Link to post
  • 1 month later...

Yea. I went pretty hard on it and just was frustrated. Where i live your not gotta have someone near buy that will know about this stuff. Cause i dont care what anyone says you cant tune a car via the internet. Its either figure it out yourself, Or dont do it at all. Im sure i will get it. The MS wasnt my only problem for some reason oil leaks always plague my motor builds for some reason. Hoping i can just let it sit a bit and it will fix itself LOL

  • Like 2
Link to post
  • 2 weeks later...
  • 1 month later...
  • 8 months later...

I'm a hardcore lurker on this project. I'm jealous because I have a 79 210 that I'm trying to get running again. Needs brake solutions badly but not rich enough to go wilwood. Plus no one has been able to give suspension advice since it's pretty shot.

  • Like 1
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.