Jump to content
DATN510

EFI info

Recommended Posts

I didn't know you had a build thread!  Cool to see the pictures bigger than my phone screen!  

Share this post


Link to post

 

The custom pistons i had made had some problems with the design. Unfortunately they damaged the block and crank, I can get them repaired but will cost more than i'd like.

 

 

Did you not turn the engine over by hand during assembly? I can't imagine it would have spun smooth enough to not feel something that would eventually take out the lower end. What happened.

Share this post


Link to post

The rist pin bore on the pistons were milled to small, causing the pin to seize.

Something that would only have been noticed at manufacturer.

They are making me new ones for free.

Share this post


Link to post

What about the cost of all the parts that broke because they were made wrong? 

Share this post


Link to post

Thanks for bringing this one back up top. I too would like to know. 

Share this post


Link to post

Hello all, Here is an update. Had some problems with the custom pistons, the pin holes were milled to small and seized in the 2 and 3 cylinders. Causing lots of damage.

I had to buy a new crank, that i got from Ratsun. bore the block to 3.46" due to scoring. I just got in the mail the new custom pistons, so hopefully ill have the engine back soon.

I did do some work on the engine bay. I tucked the wires through the frame and repainted the engine bay all white. ill post some pics soon and keep you up to date.

Thank you for asking about the progress.

Mike

Share this post


Link to post

Hey guys and girls,

Hows everyone doing?

Well here is an update. I got the engine all put back together and installed, with the new tranny, clutch and of coarse the turbo.

I'm having alot of problems hopefully you can help? My timing is spot on, but to get her running I have to drop the oil pump and set the rotor 2 slots clockwise to get her going.

I have 2 dizzy's i'm working with, the matchbox dizzy and the custom optical dizzy with the megasquirt aftermarket 24-1 disk.

The timing at idle is 30-35 degrees, I do believe it is BTDC. I did have her running with the Nissan trigger disk, but when I gave her gas it just died!

I am so frustrated with this! and would almost like to go back to the fuel injection. But it would cost to much time and money.

Please someone help! Of coarse I will post pics soon.

Thanks.

Mike 

  • Like 1

Share this post


Link to post

I can't believe how much trouble you've had with the turbo build!  Jezz!  

Share this post


Link to post

This seems to be an old thread but if anyone is interested:  About 20 years ago when I built a EFI L18 510 for a customer/friend.

I used a 280 Z ,manifold, cut out the two center runners, reworked the plenum to match up.. That was the most difficult part on the manifold as when the center was cut out there was a mismatch in alignment. I used the EFI parts from a 200sx and electronic ignition distributer from a later l20. I was able to tweak the air flow meter and some other settings. It worked out great. I don't remember a lot of the details after 20 years but I built some pretty mean 510s before I turned the shop over to my son. I probably notched the intake ports to be like the 280.

Share this post


Link to post

Hello everyone, I have a really good question for ya!
So I did some more research regarding my timing issues that i've been having some problems with, and came up with a possible solution. As far as the timing issue I believe I have is that my cam is opening the valves to soon, and not allowing the full amount of fuel to mix and compress. which means I believe that the spark is to soon, only igniting 
maybe half of the mixture. my question is, can this be fixed through the distributor timing or is it a mechanical issue? Where I have to set the cam lobes back a tooth or two on the sprocket. Of coarse I know about the valve clearance hitting the top of the pistons. In the new forged pistons I have gotten< after the old ones seized the engine due to a design issue. They placed a grove at the top of the pistons where the valves come down at. The old pistons did have a make on them where the pistons did hit the valves, but didn't damage the valves. although that was the only time I had boost. at this time I have no boost, I did a boost leak test and did have a few leaks and fixed them. I did some thinking about the distributor and believe that no matter where i align the distributor, I wont be able to get proper retard to get this to work right.
I did get the new CAS distributor to get the car started in toothed wheel mode with the Megasquirt, but unfortunately my fuel pump relay started turning off and on. Causing only two of the four injectors to work. which is another question I have if anyone can help me with? I know Matt Crammer is on this site and he's the megasquirt guru! hopefully he can chime in?
Thank you in advance for any info on my problem.
Mike

Share this post


Link to post

[/url]">http://20160622_165439_zpse3sficsj.jpg

Here's a pic of the engine bay, I tucked the wires, sealed some holes, some bondo work to smooth the edges, did a base coat and 3 coats of clear

 

20160822_162430_zpsm8orbypq.jpg

 

Painted the block and installed. If you can see the wires at the top right?

 

20160823_153429_zpsaid3svfe.jpg

 

ARP bolts and timing cover.

 

20160823_153437_zpsusrbinnk.jpg

 

20160823_190217_zpsdwkahjkm.jpg

Head on!

 

20160825_144546_zps7praoysc.jpg

Turbo on with some wraps.

 

20160823_190157_zps12lhzva3.jpg

 

20160903_231407_zpsgmntjllp.jpg

Plenum and fuel rail.

 

 

20160903_231416_zpsrdoka2mi.jpg

Starter, filter and some hoses.

 

20160906_163916_zpstf0xraws.jpg

Ill post more later.

Take it easy everyone!

  • Like 1

Share this post


Link to post

Wow man that is beautiful. I want a turbo manifold now. If I can say one thing is and don't hate me is your fuel line. It would look so much better routed up from behind the engine instead of the stock location from the passenger side all the way over.

 

 

But wow that is bad ass. Bravo my friend bravo.

  • Like 1

Share this post


Link to post

Hello all, I know its been awhile. i have more pics to post soon.

Also does anyone have an adjustable cam gear for an L series engine? Im having problems with compression and need to set back the cam.

any help would be great.

Thanks,

Mike

  • Like 1

Share this post


Link to post

Datn510, I use the Kameari timing gear for my L-28 builds, the same gear will work for you.

 

it's pricey, around 200 bucks delivered. I had to get mine in from Japan when I had some friends stationed at Okinawa.

 

What problems are you having? Retarding the cam will delay cylinder pressure and help with detonation, but won't change compression, advancing the cam will build cylinder pressure at lower RPM and sometimes increasing the detonation risk.

 

You can use the slack holes to advance the cam 4 degrees or 8 degrees, and by slipping 1 tooth on the chain you can retard by 9 degrees. So, move from pin hole 1 to 3, then slip a tooth, that retards the cam 1 degree...that's all the usable retard you can get in a stock gear, but you could advance it up to 8 degrees if you need to advance the cam.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.