Jump to content
DanielC

My Ratsun Datsun 521, now with L-20-B

Recommended Posts

This thread is long enough even I do not remember where stuff is.  Because I can edit my own threads at any time, I am going to add a table of contents on my pages.  But not all at once!

 

On this page:

Purchase

Engine inspection

Floor inspection

Roof patch plate

Engine bay tiding up, removal of extra brackets.

Carburettor issues

Test running, auxiliary gas tank.

Engine removal, replacing leaking core plug

Heater removal

Pressure test of cooling system, engine and radiator not in truck.

Start of body work, on lower grill rail

 

 

I bought this truck. MicroMachinery delivered it to me on Saturday April 10, 2011.
Here is a picture of it just after delivery, in the drive way.
Arrival.jpg
Here is a close up of the right door, complete with stuff growing on it.
DoorGrowth.jpg
I spent part of the day cleaning it out, getting rid of old garbage like this, TennisRackets.jpg
Here are more pictures.
RightFront.jpg
LeftFront.jpg
Front.jpg
Here is the engine.
Engine.jpg
Engine2.jpg
I took the cam cover off, to find out where number one cylinder was timed, and it looked like this. Pretty clean, a nice surprise.
CleanValves.jpg
I did not get an alternator with this truck, but they left the bolts.
AltBolts-1.jpg

I bought this truck mainly for the parts, but I think it might have potential as a runner.
I did a compression test on the engine. All four cylinders showed 145 to 155 PSI, with the throttle closed. The throttle was stuck from the truck sitting. It was last registered in 1991.

After playing with the points, and the timing, I could get the engine to fire, and run briefly by pouring a little gas in to the carb.

Share this post


Link to post

How is this so clean??? :)

 

CleanValves.jpg

 

 

I see it has the 1600 OHC cover too.

Share this post


Link to post

Good news. That looks amazing under the valve cover! I wish I could have kept it, but alas, I couldn't. It went to a good home, and I have no doubts that you'll be able to resurrect this sleeping beauty. :)

  • Like 1

Share this post


Link to post

That should be a very cool Ratsun. A little elbow grease & throw a few parts @ her. Good luck & keep us posted. :cool:

Share this post


Link to post

Good god im always so surprised how folks on here resurrect things that look like a definite parts truck! Need that 1600 valve cover??? :cool:

  • Like 1

Share this post


Link to post

Now, some bad news. Here are pictures of the floor, almost good enough for Fred Flintstone.

Right side.

RightFloorHole.jpg

Left side.

LeftFloorHole.jpg

The roof has this unique feature, and it has leaked a little on the inside.

Roof.jpg

 

The left side of the engine bay had this odd bracket, and wood shelf.

BracketShelf.jpg

And this bracket by the horns.

Bracket2.jpg

I removed them tonight.

BracketsGone.jpg

There are also two red wires spliced into the ignition coil wiring, that go to a toggle switch located above the hood release handle in the cab, a crude anti theft device.

There is also an ammeter added to the wiring, here is a picture of how it was spliced into the wires.

BadSplice.jpg

The bolt without any insulation was just hanging loose between the starter, and oil filter. Other electrical issues on the right side of the engine bay is the voltage regulator mounting.

VoltMountWrong.jpg

The voltage regulator is mounted to one of the battery tray support rods. If you look close at the picture, you will notice the ground lug with two black wires just hanging out in space.

 

I removed the radiator, and when I took the upper radiator hose off, I found this.

TstatCover.jpg

Yesterday, I did a pressure test of the cooling system, and I found a leak in one of the core (freeze) plugs in the engine block.

 

I also pulled the carburetor off, there were only three nuts holding it on the manifold, instead of four. I am sure you all have seen an L-16 engine without a carburetor before, but here is a picture anyway.

CarbRemoved.jpg

 

And here is a picture for Micromachinery, of the bed. with only a radiator in it. He will remember old leaves, pieces of bamboo, some trash, a piece of concrete, and other crap that was in the bed.

CleanBed.jpg

Share this post


Link to post

Today, I played around with the carburetor. I sprayed some penetrating oil on the throttle shafts, and was able to get them free to move. Looking into the secondary bore, part of the gasket that goes in between the throttle plate, and main body of the carburetor was in the bore. I found the screws holding the two parts of the carb together were loose. I found a gasket in my gasket collection, and put it in, and tightened up the screws.

Then I got a small gas tank from a riding lawnmower I scrapped last year, and a piece of 1/4 inch hose, and used it to gravity feed the float bowl. Almost immediately, gas started to leak out from under the sight glass. I took the metal piece that holds the sight glass, off the carb, and the glass, and found a crack in the sealing ring. I then took the sealing ring from another old carb i had, and put the carb back together. I probably should have checked it again for leaks, but since I found the obvious reason for the leak, I just put the carb back on the manifold of the truck.

Picture time!

Getting the carburetor off a L-16 engine can be a pain. Here is a picture of a wrench I modified to get the hidden nuts that hold the carb to the manifold.

CarbWrench.jpg

here is the wrench being used.

WrenchUsed.jpg

 

Everybody who works on these old cars meeds some of this:

GasketMaterial.jpg

And the tools to cut it,

GasketTools.jpg

And a punch to make holes,

HolePunch.jpg

So you can do this,

CuttingGasket.jpg

and end up with these.

MadeGaskets.jpg

  • Like 1

Share this post


Link to post

Hey, that bed cleaned up pretty nice! Bummer about those holes in the floorboards, though :( I didn't know it had gotten that bad. Enjoying the badminton rackets?

Share this post


Link to post

I think I may have a special place for the badminton rackets Friday morning. That just happens to be garbage pick up day for me.

I have seen several project threads here about repair of floorboards in many other vehicles. I was not totally surprised. I do have other cabs with better floor boards, but they have major front end damage. I could use the good parts from two trucks to make one good one.

Even with the holey floorboards, I am still happy with the truck. Tomorrow, I may see if the truck will run on the carb, instead of just dumping gas through it. I am in the process of evaluating the engine in the truck. The engine might be the surprise bonus of this truck.

Share this post


Link to post

This morning, I took the lawnmower gas tank I have, and hooked it up to the fuel pump on the engine like this.

LawnmowerTank.jpg

And then I thought, if I hold the tank above the engine, maybe gas will just run through the fuel pump, and into the carb, like this.

TankElevated.jpg

 

Sure enough, gas started to flow through the fuel pump, and fill the float bowl on the carburetor.

 

Well, with a full float bowl, and a battery hooked up, lets try to start it. Put the key in, and with one hand holding the choke on, and the other turning the key, it started! But it would die as soon at I let the key go out of the start position. I did this several times. I then hot wired it, by running a wire from the ignition side of the ballast resistor, to the battery positive terminal, and it started, and ran. I then quickly checked the oil pressure. It has decent oil pressure!

 

It starts, and runs! I reset the points, by eye. I set the timing by getting it close, and then advancing the distributer slightly, again by eye. The carb was just cleaned up a little, and the throttle shafts unstuck. No adjustment on the carb, just put it on.

 

Now, I need to pull the engine, and replace the core (freeze) plugs, and see if it will hold water. Next, get the clutch working, and at least the emergency brake, so I do not have to depend on blocks, or chaining it to a tractor to stop it from moving.

 

It is well on its way to becoming an Automobile again. a vehicle or mechanism capable of moving itself.

Share this post


Link to post

They say it is going to rain pretty steady, for a few days. So I moved the new 521 in to the garage.

InGarage.jpg

  • Like 1

Share this post


Link to post

Good job on getting it to run.

That's a motivator if I ever heard of one.

Share this post


Link to post

INDY510 wrote:

"FUEL FILTER????? ........ :huh: "

 

The plastic tank I used is clean inside. I used a new piece of hose to connect it to the fuel pump. Pretty much any dirt in the carb will be from another source.

I have not even looked inside the gas tank on this truck yet. I will probably drop it out of the truck, to clean it out.

When I hook up the gas tank for the first time, on most of the vehicles I work on, I use a marine fuel filter that has a filter element about the size of a Ford FL1-A oil filter, sitting on top of a sediment bowl.

Share this post


Link to post

 

The left side of the engine bay had this odd bracket, and wood shelf.

BracketShelf.jpg

 

 

secondary battery tray?

Share this post


Link to post

I found the pictures I took today, When I download the pictures from my camera, before I down load them to the computer, I rename them. That way, the pictures do not just have a meaningless number.

I removed the seats today, and wire brushed the floor. I also removed the seat belts, and an old fire extinguisher mount.

Before cleaning.

RightFloor.jpg

LeftFloor.jpg

After cleaning.

RightFloorClean.jpg

LeftFloorClean.jpg

Here is what the front of the floor looks like.

RightFrontFloor.jpgLeftFrontFloor.jpg

 

I also pulled the engine today. I wanted to pull the engine, to clean it, and the engine bay. EngineOut1.jpg

EngineOut2.jpg

 

And here is a typical engine bay.

EngineBay.jpg

 

And in an area where I would expect a lot of rust, on the battery tray, it is not bad.

BatteryTray1.jpg

Share this post


Link to post

I started today, doing some clean up, and organizing. If I cannot put bolts back in the part, I put them in a bag, and label the bag. The bag then goes into a parts box.

BoltBag.jpg

After doing that, I lifted the engine and then slid my parts washer under the engine, and cleaned the engine a little more.

EngineCleaning.jpg

Here is another reason I pulled the engine. I had to replace this plug in the block. you may recall, at the beginning of this thread I made mention of the block having a bad core (freeze) plug. Here is the new plug in the block, I actually put it in last night.

NewCorePlug.jpg

Here is the plugs I used.

BlockPlugs.jpg

Because I had one bad plug, I needed to check them all. Even the one in the back, under the flywheel. Before removing the flywheel, I put the engine at TDC, number 1. (and 4).

TDC.jpg

And after putting the engine there, I put a mark on the flywheel.

FlywheelMark.jpg

Then I removed the flywheel. This how I held the flywheel from turning when I loosened the bolts.

FlywheelRemoval.jpg

With the flywheel off, I did some more cleaning.

 

Then I set up the engine to pressure test the cooling system. I wanted to do the entire cooling system, so I needed to remove the heater from the truck.

The nuts on the studs for the heater were rusty. Like this.

Bolt_Rusty.jpg

The first step is to spray some penetrating on the studs, and nuts. You really do not need a picture of that, do you? Then you wait. Let the oil penetrate. It is much easier to wait, than to repair broken bolts. After waiting a while, try to loosen the bolt, or nut. If the nut goes a few turns, and then starts to get harder to turn, STOP! Spray some penetrating oil behind the nut, and then tighten it up again, but not tight.

This is a wire wheel you can get at Home Depot.

WireWheel.jpg

Put it in a drill.

WireWheelDrill.jpg

and use it to clean the rust and crud off the bolts you are trying to remove.

Bolt_Clean.jpg

 

After removing the heater, I pushed the engine on the stand under a rafter, and used pieces of twine to hang the radiator in front of the engine, and the heater behind the engine.

PressureTest1.jpg

Here is a picture of the pressure test pump hooked up to the radiator that came with the truck.

PressureTestPump.jpg

If you look close, you can see a problem with the radiator, in the last picture. Here is a better picture, of a bad radiator.

LeakyRadiator.jpg

Conveniently, I just happened to have spare radiator.

SpareRadiator.jpg.

I took off the radiator that came with the truck, and hung the spare radiator, and tested again.

I found the lower radiator hose was leaking. I had a spare on of those, and changed it. Then I found a leak in the short heater hose, and changed it with another spare hose I had.

Finally, I got the cooling system to hold pressure.

HoldingPressure.jpg

This was after sitting for a few minutes. Success!

 

Before hanging the heater, I tested the motor on it.

HeaterMotorTest1.jpg

It is running in the picture. Really it is.

This is the picture of the battery hooked up to the heater motor.

HeaterMotorTest2.jpg

 

Today, I also went and got some parts for the engine. I got a hose for the PCV system, the hose was gone on this engine. Here is the new hose I got. I got it from Tonkin Nissan, in Wilsonville.

PCV_Hose.jpg

While there, I also got an oil filter.

OilFilter.jpg

and then I drove up the road to Schuck's I mean O'Reilly auto parts, and got some Spark plugs,

SparkPlugs.jpg

 

So, that is enough for today. Maybe more tomorrow.

Share this post


Link to post

Today, I did some more work on the engine. I have a Mitsubishi 50 amp internal regulated alternator I put on the engine, but I need a longer belt to drive it. I also put a matchbox distributer on it. the distributer came from a 1980 200SX, with a NAPS-Z20-E engine, and I did not get the pedestal or the plate that holds it in place. I did some wiring on the truck, to accommodate the distributer.

 

I also did some work on the front end. I removed the front bumper, the lower valence panel, and the trim around the headlights, and grill.

Left front of truck:

LeftFrontTrimOff.jpg

Right front of truck:

RightFrontTrimOff.jpg

Share this post


Link to post

This is great. I'm stoked to see that this truck isn't only going to not be parted, but is quickly becoming a very respectable runner. Randy would be so proud.

  • Like 1

Share this post


Link to post

On this page:

Engine put back in truck.

Matchbox distributor install, no pedestal, or timing plate.  Re-index oil pump spindle.

IR alternator install, and testing.

Big battery cables built, and installed.

Front end body work started.

Combo meter repair, and pinout connections.

Headlight current fusebox bypass relay.

Rebuilt taillights installed.

 

Friday afternoon, I decided I need to do something about the exhaust manifold. Only one bolt was there, holding the exhaust pipe on the truck. Of course, when pulling the engine, that bolt broke. So I went back to my in house parts supply, and pulled an old manifold off an engine that definitely needs rebuilding.
Friday late afternoon, and I need a gasket for the manifolds if I want to keep going on this project truck.
About 4:00 PM I call Clackamas Auto Parts, in Oregon City. Talk to Art, at Clackamas, and ask about the gasket for my engine. He says, I have to see what is available. I say I will call back in about a half hour. When I call, he gives me several options, and one is having a head gasket kit, Saturday morning.
I spent the rest of Friday evening taking the front end trim, and the bumper off.
I call Saturday morning, and at 8:34 AM, the gasket set is in my possession. I also get some wire, and I need to get a different belt for the alternator, the pulley in it is bigger, and it will not fit as close to the engine. I get two possibilities, and bring it all home.
So Saturday, I put the engine back together, and put it in the truck.
A simple statement, but it involved a lot of cleaning of parts, and time consuming boring stuff.
Cars do not go together in a half hour like they show on Saturday morning TV "Hot Rod" shows. The camera ia still in the garage, pictures later.

Share this post


Link to post

Worked on electrical tonight. I got power to the ignition system, but the oil, and the ign light do not come on in the dashboard.

I am trying to figure out exactly is going on with the alternator wiring. the truck had no alternator when I got it. The truck also had an aftermarket oil, pressure gauge in it, and I can not find the wire for the oil pressure light switch.

Share this post


Link to post

It runs, and it charges its own battery! Here is a picture of the engine as it sits today.

RunningEngine.jpg

I did some work on the engine. I pulled it, cleaned a lot of gunk off it, put on a EI "Matchbox" distributer, and put in an internal regulated alternator that I have had laying around for several years.

The alternator charges about 14.5 volts, and put out over 30 amps, in the short time I ran the engine. I am running the engine briefly, because I have no radiator hooked up to it, yet. I plan on doing some front end body work on the truck, and the radiator would be in the way.

After a short run, I pulled the spark plugs, and did another compression test, this time with open throttle. #1, 177 PSI. #2, 168 PSI. #3, 162 PSI. #4, 169 PSI.

This is how I hooked up the coil to the stock wiring of the truck.

EICoilWires.jpg

The red and black paired wires go to the coil plus, and minus. Red plus, in case you were wondering.

This is what I did at the distributer.

EIDistWires.jpg

I took the tape off the original distributor wires, and found I could easily remove the wires I was not longer using. I used ring terminals at the coil connection, and put them under the spade connector on the positive side, and just put the black wire under the nut on the negative side of the coil. I then had only to put the temperature sender wire back into the harness, it goes beyond the distributor the the temp sender. I need to scrounge a junk yard, and find a factory distributor connector. For the details on electrical look around Ratsun. The information is there. Here is a clue. On the EI distributor, the terminals are labeled B, the first letter of the word "Battery" and C, the first letter in the word "coil". If you look below the distributor, you will see a black wire, under one of the small bolts that go through the head bottom surface into the front cover. This wire goes back to the spade connector by the vacuum advance, to ground the distributor.

 

This is how I timed the distributer. I set the engine about 12.5 degrees before TDC.

BTDC125.jpg

Made sure I really was on number one cylinder, not number 4.

TDC1.jpg

I then put the distributor on the engine, and centered both timing adjustments. In my case, the rotor was pointing the wrong direction, and between two towers on the distributor cap. I dropped the oil pump, and turned the distributor drive spindle around until the rotor was pointing at the cap tower closest to the front of the engine. This is where my distributor drive spindle ended up to time my distributor correctly.

OddSpindleLocation.jpg

 

And this is where the distributor rotor pointed.

P1010400.jpg

 

That is my number one tower.

P1010401.jpg

 

Then go counterclockwise around the cap, plugging in spark plug wires. 1, 3, 4, 2. Finally, I loosened the small bolt holding the distributer, and lined up the teeth on the wheel inside the distributer, to the pickup teeth, like this.

FiringPosition.jpg

 

That is where my engine is currently timed. How many degrees before TDC, I do not know, but it runs, and I confirmed the EI distributer works. I do not want to run the engine long enough to check the timing, no radiator, yet.

 

 

 

Here is the alternator.

Alternator.jpg

IR alternator hook up:

Ground the case of the alternator. I went back to the stock (I think) factory wiring for the charging side of the alternator. A short white wire going to the positive terminal on the starter, and the positive starter cable carries the current to the battery. Even though the old voltage regulator is removed, you must reattach the lug with the two black wires back to the body of the cab, where the old voltage regulator was mounted.

The IR alternator has two other terminals on it. "S" and "L". L is for the idiot Light. The light grounds through this terminal, and needs a switched ignition source supplied to it. The "S" terminal is where the alternator measures the voltage, and regulates to that. The "S" terminal needs to be hooked up to a switched battery voltage. Do not wire it directly to "always on" power.

 

I have some electrical problems with my truck. The key starts, and runs the truck, but no lights come on in the combo meter. There is the wiring needed to start and run the truck, that is working.

 

This is how I hooked up the two small terminals to test the alternator.

AltHookup.jpg

Again, I used a piece of red and black paired wire. The black wire in the pair goes to the "L" terminal, (it supplies a ground) and red wire goes to the "S" terminal. You can see then paired wires in between the battery and number three spark plug. The red wire, and test lead goes to the positive battery terminal. The test light ground clip also goes the the positive battery terminal. The probe of the test light is hooked up to the black wire, going to the "L" terminal on the alternator.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.