Jump to content
Icehouse

CAN/AM Production easy wiring boxes for EFI works for KA's SR's VG's CA's and more

Recommended Posts

big vouch for icehouse's box. just got it in the mail a couple days ago. he answered all my questions in a timely manner too.

Share this post


Link to post
got lucky, icehouse had them available and sent it out right away. got here in about a week and looks great. couldn't have been easier. just need to get around to installing it. thanks!

 

 one question, point me toward a diagram for a ka24de to a 69 510 goon? (i have to look again and see if it came with any paperwork........ i was so excited to get it i just took it to the shop without paying attention for any instructions, haha)

 

  thanks again.

 

 

   if you want to get one, just send him a PM and he will let you know if he has one ready, send him a paypal, and watch your mailbox. easy.

     be patient, he's busy like the rest of us, but he got back to me in a day or 2...

 

In the first posting he installed this link to go to his how-to-section in wiring this bad boy all up. in addition, there are some FSMs there for you too  :thumbup:

Hope this helps.

Ross

Share this post


Link to post

I do my best at answering all the question I get and getting the orders out as quickly as I can.  My favorite thing is hearing about another successful EFI swap! 

  • Like 1

Share this post


Link to post

Can/Am box is in my hand.  Another happy customer, thanks to Icehouse!

Share this post


Link to post

It's a better idea tio PM him ;)

Share this post


Link to post

I just pmd you..:)

Just want to get in line, pm me with payment Info and est. delivery time ... Thanks!!

Share this post


Link to post

Help! Fuel pump relay wire is removed from my ECU plug. Is there another pin I could leech that would trip the relay the same as the fuel pump? I can't get the connector out and any more tampering could damage it beyond repair. Could I stick a flat slit crimp in it? This is my last wire.

Share this post


Link to post

I have a 510 with a ka24de swap. Been driving it for about a year with no issues. Took it out today, luckily just done the street & I noticed it started hesitating so I took it back to the house & It just died. The can am box usually lights up yellow, green & red. When I turned the key on I didn't hear my fuel pump prime up. Check the box & I had a burnt 20 amp fuse on the can am box. Changed it but still the same. Only the yellow light on the can am box lights up.? Seems like only a third of the box is working. I checked the rest of the fuses, good. Switched the relay boxes around with no luck. Something made that fuse burn on the can am box. Has anyone had an issue like this? I hope the box didn't fry...

Thanks, Greg

  • Like 1

Share this post


Link to post

×

Important Information

By using this site, you agree to our Terms of Use.