Jump to content

NEWBIE


KA620KC

Recommended Posts

Whats up everyone! Been snoopin around the site for a while now thought I'd finally post up on here. Found quite a bit of information on here for my build up of my 77 620 King Cab. It originally had a camper shell on it and was used as someones construction/paint truck. I have since yanked the shell, lowered it and pulled the L20 out. In its place now sits a KA24DE.

 

2010-11-30231048.jpg

Link to post
  • Replies 61
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Yeah I live very "near" mydailyroutine :cool:

 

No custom mounts at all. We removed the entire EGR system and all the accompanying vacuum lines, so we were able to reuse the stock 620 lower mount and the stock KA upper mounts.

 

No she's not running yet. Still gotta finish running all the wiring, doin a "mild" wire tuck, run the relays, fuel pump, get the drive shaft measured and shortened and then still find a stock exhaust manifold. If anyone's got a STOCK exhaust manifold I've got a brand new never installed Hot shot header for trade plus $50.

Link to post

2010-08-09-131654.jpg?t=1293519023

 

Just a quick look at what the engine bay looked like after pulling out the L20.

I'm hoping to not let this "motor swap" snow ball. Here's a picture of my last project that went from a simple "dent' repair to a full on rebuild.

BaggedVII.jpg?t=1293519345

This small dent:

IMG00044.jpg?t=1293519579

Turned into this:

NewPaint10.jpg?t=1293519750

Link to post

can you make a thread about the wiring.... Im doing a Ka swap too and it would be of great help if you can make a diagram or video of your work.:D

 

 

SERIOUSLY!?!?!?!?!?!

Dude!! The frick'n search feature here works!!!!! USE IT!!!!!

 

 

 

Sorry :rolleyes: .......Nice truck.

Link to post
  • 4 weeks later...

Alrighty guys I need help!! What accelerator cable is everyone using for the Twincam swap?? I tried using the search feature and going through other peoples builds but I can't seem to find any solid info as to what cable to use. I'm using a KA out of a 93 240sx. Do I use the same cable?? I tried one from a 720 with the KA but its waaaaay too short. Any help would help!!

Link to post

oh yeah heres a few update pictures.

Got the radiator installed with a cooling fan and I was able to "hack" up a upper hose from a Ford Diesel and I also relocated the battery to the cab and rerouted the intake to where the battery would be.

2011-01-22142528.jpg?t=1295937302

 

2011-01-22142549.jpg?t=1295937302

 

2011-01-22140748.jpg?t=1295937302

Link to post

I used a throttle cable from a pathfinder. (there are two sizes, long and way too friggin long, lol). Also, the stock KADE cable should work just fine.

 

I'm thinking that radiator might be a little small though, lol. (one of the KA truck guys to tell you for sure though)

Link to post

yeah i figured it might be a little small. But its temporary for now, I just wanna get her running already I've been told my OCD and "snowballeritis" are slowing me down from finishing her already!!! The goal is to have it ready by March 6th for the swap meet in sac.

Link to post

Got a little more done today. All hoses are clamped and routed, fuel pump installed (forgot the filter, need to get one) and clutch master installed. Next on the list is the wiring (woohoo i'm soooo excited), measure the driveshaft to get it shortened and then try to source out an exhaust manifold.

Link to post

Got a little more done today. All hoses are clamped and routed, fuel pump installed (forgot the filter, need to get one) and clutch master installed. Next on the list is the wiring (woohoo i'm soooo excited), measure the driveshaft to get it shortened and then try to source out an exhaust manifold.

 

Did you use the stock cross member from the l20? And if so, did you need to do any drilling? Im doing the same build myself and dont want to run into problems, I want to be prepared before hand. Already got my tranny in but not sure if im gonna have to run it back on the cross member once dropping the engine. Wiring is done too.:D

Link to post

I used the 620 tranny mount and the 620 crossmember. I did have to slot the holes about a 1/2". And I am using the 620 driveshaft. I still haven't measured it tho but if I were to "guesstimate" i'd say the "short" portion of the driveshaft would need to be shortened about 3". As for the wiring I am having a HEEEEELLLL of a time doing it. I'm sure its easy but I just can't seem to get my head wrapped around it. Any way you could take some pictures of your wiring? I need visuals hahaha I hate reading wiring diagrams!!

Link to post

Missed this one... :D

 

Do I use the same cable?? I tried one from a 720 with the KA but its waaaaay too short. Any help would help!!

 

I used a Pathfinder cable, I think it was out of an 88 with the V6. Tight fit at the firewall, check my build thread in my sig for pics.

 

I used a throttle cable from a pathfinder. (there are two sizes, long and way too friggin long, lol). Also, the stock KADE cable should work just fine.

 

I'm thinking that radiator might be a little small though, lol. (one of the KA truck guys to tell you for sure though)

 

Not sure which cable I got, it's really long, but it fit into all the KA's accelerator cable clips.

 

I'm using the stock 3-core radiator from my 77. Works great with the electric fan.

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.