Jump to content
HRH

Speedometer Gear Issues

Recommended Posts

I have an issue related to photos Mike posted on page 2, I just pulled out my black speedo gear to replace it with a yellow gear as I just switched over to 3.3 gears in my 521 kingcab, the speedo gears are not the same length, it is a 1985/86 short shaft 5spd, is this a short shaft 5spd only part?

 

002.jpg

 

You can see the mount tab is part of the gear also(black one).

So did they ever make a mileage option 720 with a short shaft 5spd in it that I could get a yellow gear out of?

  • Like 1

Share this post


Link to post
3 hours ago, wayno said:

I have an issue related to photos Mike posted on page 2, I just pulled out my black speedo gear to replace it with a yellow gear as I just switched over to 3.3 gears in my 521 kingcab, the speedo gears are not the same length, it is a 1985/86 short shaft 5spd, is this a short shaft 5spd only part?

 

002.jpg

 

You can see the mount tab is part of the gear also(black one).

So did they ever make a mileage option 720 with a short shaft 5spd in it that I could get a yellow gear out of?

That definitely looks different then the ones I have seen...  I'm using the black gear in mind, I have the stumpy 5spd also.... I used one from my 63 series 4spd but i had to rotate it 180 and grind a new notch to get it to engage properly....

I think i have a long  yellow one from my 4spd that I dont need ... I'll trade you for the black one you have..... 

 

20180519_215411.jpg

  • Like 1

Share this post


Link to post

This is the one I am currently running in mine next to the yellow one...

 

20180517_183421.jpg

  • Like 1

Share this post


Link to post

I had no idea the shortys were so long. The shorty speedometer pinion IS in a different location than the long ones so maybe this is what it is. The shorter aluminum with yellow gear is definitely from a 71B long.

 

All good info, thanks.

  • Like 1

Share this post


Link to post

The black one I have is 3.75" long/tall the way you measured yours, I can find black ones but finding a yellow one, well I didn't think they existed, and if they do they were likely only in the 1985/86 regular cab/short box trucks with the mileage package(Z20 block), that would be the rare of rare.

004.jpg

I would happily trade you a black one for that yellow one you have, it looks to be 3 5/8ths inches tall but I suspect that will work, I will PM you.

Edited by wayno
  • Like 2

Share this post


Link to post
On 7/27/2019 at 9:23 PM, wayno said:

The black one I have is 3.75" long/tall the way you measured yours, I can find black ones but finding a yellow one, well I didn't think they existed, and if they do they were likely only in the 1985/86 regular cab/short box trucks with the mileage package(Z20 block), that would be the rare of rare.

004.jpg

I would happily trade you a black one for that yellow one you have, it looks to be 3 5/8ths inches tall but I suspect that will work, I will PM you.

 

I was lucky enough to trade with wayno and since he was much quick than me with the shipping I was able to compare the 2..... 

 

20190802-045131.jpg

 

While I have proved in my own transmission that they will engage the

black one is definitely a little different... 

And about 1/8 inch longer.... looks like the gear its self is even a little different.... 

 

20190802-045244.jpg

 

20190802-045226.jpg

 

So the stumpy 71b from the 85/86 720 is definitely an odd pinion assembly...

 

 

 

  • Like 1

Share this post


Link to post

The worm drives on the main shaft are either metal or some later are plastic but the same otherwise.  1/8" is nothing... the worm only engages about 1/4" in the middle of the pinion gear.

  • Like 1

Share this post


Link to post

I put the yellow gear I got from Crash in today, I had to cut a new groove 180 degrees out so the teeth would engage the teeth on the drive shaft in the tail housing.

 

001.jpg

 

It appears to work just fine, I drove the truck twice today, I went past one of them radar speed signs and it said I was doing 28mph when my speedo showed 30mph.

I am leaving it in there, as I recall the black gear was 2mph off also.

While driving down the freeway I showed 2150rpms at 60mph, 2500rpms at 70mph, and 2850/2900rpms at 80mph, I have P205/70R14 tires on it all the way around, seems like with these tires I would be going faster than I am showing.

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.