Jump to content

jchristians

Members
  • Content Count

    92
  • Joined

  • Last visited

Community Reputation

1 Neutral

About jchristians

  • Rank
    Advanced Member

Profile Information

  • Gender
    Not Telling
  • Location
    Siloam Springs, AR
  • Cars
    1971 Datsun 1600 pickup, 1969 BMW 2002.
  1. Selling PERFECT 521 dash:http://www.ebay.com/itm/Datsun-521-Dash-Dashboard-MINT-/220959679489?pt=Vintage_Car_Truck_Parts_Accessories&vxp=mtr&hash=item3372392401#ht_500wt_1074
  2. SOLD: $4,300 Transplanting to Oklahoma City.
  3. yeah, pad was stripped and metal painted. Definitely recommend doing this! Durability baby!
  4. Here is the item #: #220953734202 Link: http://cgi.ebay.com/ebaymotors/Datsun-?cmd=ViewItem&_trkparms=algo%3DLVI%26itu%3DUCI%26otn%3D1%26po%3DLVI%26ps%3D63%26clkid%3D6371649301944201287&_trksid=p5197.m7&item=220953734202#ht_2414wt_985
  5. ...is now on ebay. In case you haven't seen it. REALLY NICE. Currently at like $3600. Sad to be selling, but, needing to simplify w/ 2 little kiddos. :(
  6. jchristians

    stereo setups

    maybe check out kicker's Comp VT sub boxes.
  7. hmmm... What were the dealer installed options?? So, they were sold w/out side mirrors??
  8. Looking to buy some NICE 1971 521 stock mirrors... victor_ryanheart at hotmail dot com
  9. That was too easy. Thanks guys.
  10. it's a stock wheel that came on the '71 521. Not really bulbuss...has the more horizontal black center and silver outline horn piece.
  11. I purchased a wheel...so, it is off the truck. Trying to figure out how to remove the center section (horn part) black and silver part. Repaired a crack and now gonna attempt to refinish (paint) part of the wheel. thanks much
  12. Thanks again guys. I will have to pull apart my weber and inspect. thanks!
  13. Looking for a really nice set of rear bumpers and brackets for my '71 521. Thanks! victor_ryanheart at hotmail dot com
  14. Thanks much for all the replies and helping me figure this out. Sorry, I forgot to mention I have a new weber 32/36...not the stock Hitachi. I also restored the gas tank...so, there is no sediment in there. New fuel pump too. I will check out the jets on the weber. Yeah, the clogged filter or clogged anything isn't making sense to me since it runs just fine for the first 5-10? minutes of driving. Thanks again!
  15. My '71 521 stalls after I drive it for a while and is warmed up. I press the gas pedal and just starts to die...very dangerous! I was thinking it was my fuel filter being clogged...I changed it a few times...then it would run fine for me to get home...but, I think it started running fine cause it had time to cool down as I installed the new filter. (: Any ideas on this? thanks much!
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.