Jump to content

Thomas Perkins

New Members
  • Posts

    15
  • Joined

  • Last visited

Everything posted by Thomas Perkins

  1. I bought a Weber idle. cut off solenoid and it wouldn't work,still have it,Want to buy it,then I bought the EMPI one and put the jet on it and it has been working great.To check the Idle cut off solenoid,you start engine,then remove wire from it and it will die .I've never had a mixture problem with mine,make sure your timing is good..I tried mine without the solenoid and it would die...The Empi doesn't come with a jet,I have a extra brand new one...Also on the nut that holds the throttle their is a clip like washer that keeps the throttle from slipping,If it is not holding,it will cause idling problems.. tighting it to tight will cause the throttle to stick.I had to deal with it and bought extra clip-washers.Also don't have the Weber idled to high,will cause the throttle to stick...
  2. You will need to get your dremel tool and grind away a little bit by the hole where it goes to make it fit or you will strip it out....My first Weber did come with it back then...my linkage is from the old Weber direct carb that is in the video...The Redline Webers don't sell the linkage that I use...Did you know that their is a filter in that big nut where the front lines fork off....Don't get your throttle nut to tight or it will stick...I have bought a Empi one and I believe the piece that goes on the end doens't come with it,I also bought a Weber idle cut off solenoid and it wouldn't work,but you can take the end piece off of it and put it on the EMPI one...I've had the Redline for a couple of years...Yes check out both solenoids and you will see the piece that is on the Weber and not on the EMPI,It might work with out it,but I never tried.
  3. I wouldn't use lock tight.I've had my Weber since Fred Flinstone got a 4 door.I have no problems using a wrench.But any way,I use a Idle cut off solenoid on mine,it won't run with out it.Here's a video I did years ago.Mine has never came loose.But you do have to change the gaskets,I bought a rebuild kit for mine for 26 bucks on Ebay.Easy to do,Also clean it up.https://www.ebay.com/itm/191571346317,Here are some gaskets...https://www.ebay.com/itm/191587475677,I keep a extra kit on hand...I also have a pioneer throttle cable,better than the OEM ones....This card came with the idle cut off solenoid back then,now I have a Redline Weber that Iused the linkage and the idle cut off my the black choke one,both carbs work the same...I did sell the other carb on 720 World..Here's another site to get Weber parts that I use.. https://www.pegasusautoracing.com/keywordsearch.asp?KeywordStart=weber&KeywordButton=Go
  4. Hi Ya'll.Back in January of 2021,My heater core starting leaking.I had a warranty from Autozone.I called them up and they said they had no more and it was a lifetime warranty part.So they refunded my money.I looked everywhere for a new one,they had used ones on Ebay.But don't replace junk with junk.So I took it to Jack,he's the guy that put my Jasper Engine in back in 2009,I now have 90,000 miles on it.But anyway,he couldn't find a new heater core.He is a master at restoring vehicles.He has a restored old jeep wagoneer with a new custom made Heating and air system in it and said He could put one in for me.I put 2 heater cores in my truck,as you know it's a job.Last time is when I took the black carpet out and put gray carpet in with dynamat.Now the complete old Nissan Heating and air system is gone,I mean everything,I hated them cables that were used to control the knobs.The A.C.hose under the hood is following the firewall and goes by the brake master cylinder to the compressor.Where the heater core hoses came thru the fire wall hole has been plugged.The blower motor is gone.The control knobs are modern.The kit was specially made for my 720.All the stuff under the dash has been replaced.But anyway,no more problems...
  5. Could be from one of your pulleys.
  6. I use WIX oil filter 51515 on my 85 Nissan 720 4x4 2.4 engine and get them at Oreilly's and they just went up 2 bucks since my last oil change.I just changed my fuel filter,it got clogged up,it was a Auto Zone part.Only had it in there for 2 years,guess my gas tank had some trash in it,also changed filter in fuel pump,Weber filter was clean.When it clogged up,the engine wouldn't start.The one i replaced it with is from Oreilly's.I use the OEM fuel pump.
  7. Here is what you may need...I bought from this site.a-one.https://datnissparts.com/fusible-link-datsun-nissan-720-diesel-pickup-truck-sd22-sd25-also-fits-z22-with-mods-24022-36w11/
  8. On my 85 720 4x4 2.4.on a cold start in the morning.I turn the ignition on,step on gas pedal and let go, then start engine,then engine cranks,rpm's goes to 2000,then I tap on gas pedal,rpm's goes to 1100 rpm's,then I tap gas pedal again,then it goes to 850 rpm's and idles there all the time.On a warm start,I turn key,tap gas pedal and it fires up.I've had my Weber for years.I also use a idle cut off solenoid.It says to adjust your fast idle screw to 2000 rpm's.You can adjust it when the engine is warm or cold,if you do it when it is warm,take air filter cover off,push throttle by hand all the way,then close the choke with other hand,then crank up,check rpm's,if not at 2000,then turn engine off,turn fast idle screw clockwise,then do the same thing,push throttle by hand and close the chock,then restart and check rpm's,if not at 2000,then repeat till it is.
  9. How long does Redline transmission fluid last? At 220 degrees, which is commonly encountered in many transmissions, the fluid is only good for about 25,000 miles. At 240 degrees F., the fluid won't go much over 10,000 miles. Add another 20 degrees, and life expectancy drops to 5,000 miles.I recently changed my Redline MT-90 Transmission fluid and it was worn out,I put it in 2 years ago and put 11,000 miles on it..I had the transmission installed 4 years ago,but it didn't have Mt-90.The guy that put the transmission in told me to change it every 2 years and use synthetic.I've had my 720 for 27 years,got 375,000 miles on the speedo.Bought it in 94 with 108,000 miles which means I have kept it running.Now I kinda just work and come home,now only drive almost 6,000 miles a year.The gears change real smooth.For some reason,he didn't use teflon tape on the drain plug and it was having a slow drip,in which i did have to add fluid.Since I have used teflon tape,it no longer leaks.Mike, you did tell me once not to use synthetic oil in the motor.I used it before you told me,and I went back to regular oil.I have a Jasper remanufactured engine,got it in 2009,now have 90,000 miles on it.
  10. If you wanna ride in my 720,you gotta have a mask on...But anyway,I've been at my job for 29 years,and plan on retiring there.We are back at wearing masks at work,we all have excepted it here and we will have to play it safe and hopefully things will get back to normal.The wife and I got our shots but we don't go around gatherings.I just feel blessed that we are doing good.Plus the company I work for is doing great.It's what you make out of life and everyone be happy...
  11. Hi Ya'll.I just cleaned my rear Differential and Rancho shocks and painted the rear end.Now I want to changed the fluid in the rear differential.My Nissan manual says to use GL-5.It says 2.5/8 pints,which means I need to buy 2 quarts.So what kind is the best I should use.
  12. Hi Ya'll.I just changed my transmission fluid.I did it before 2 years ago.I used the same fluid as last time.Redline MT-90.It took about 2 quarts,I put teflon tape on the drain plug and fill plug.My Transmission is only a few years old.I used a pump from Harbor Freight.What I did was,got a mobil one quart oil container since it has the big opening,and the pump fits in it,and the end part of the pump on the hose clips in the filler hole in the transmission and stays put.The pump is only 8.95.I have no trouble using synthetic oil.No leaks.No particles was in the fluid,don't ever grind the gears.Transmission is so smooth.https://www.harborfreight.com/gear-oil-and-fluid-pump-61746.html.
  13. I had the same problem,it was the yoke on the transmission.I paid 135 for a new one.it had grooves in it,still have the old one.Like everyone one else said,I had the u-joints replaced and other people said that is the problem.I had a transmission installed and he said it needed a yoke,that was 4 years ago.I am waiting on my Redline MT-90 fluid,should be here Thursday,then I will change it,last time I changed it was 2 years ago,I used MT-90.The best for our Nissan.The way the transmission guy was able to find out that it was the yoke,he had it lifted in the air and started it and drove it and seen the yoke shaking. Safe for brass synchros, as it lacks the reactive sulfurs found in most GL-5 oils that cause damage.It takes a hair less than 2 quarts,manual says 4 and half pints,but not right.I am going to use teflon tape this time on the drain plug cause it leaks,even the transmission guy didn't use it and it leaks,then you will have to keep adding,the side plug doesn't need it.
  14. Thanks,how do I post pictures here.
  15. I had a custom made A.C. and heater system installed in my 85 Nissan 720 4x4 back in January 2021.Everything,I mean every Nissan part is gone.The switches with the cables are gone,everything under the dash is gone,The A.C hose is gone with new one rerouted.Where the heater core hose came thru the firewall is gone,hole is plugged.The electrical wiring is redone.New compressor,new dryer.The blower motor is gone with all the under dash vents.Old Heater core is no more.I went all out.The same guy that installed my Jasper engine back in 2009 did it.I now have 90,000 miles on that engine.I would take some pictures and post them but can't figure out how to.I just spent a lot on my 720,new paint job,new tires and rims,new exhaust new brakes.Tell me how to post pictures and I will show you all.
  16. My 85 Silver Bullet...

    1. datzenmike

      datzenmike

      Thomas, if you click on the BROWSE button below the Rats 'n Wrenches logo on the top left of the page all the different Datsun forums will open for you. If you would like to present your 720 or talk about it Try the 720 forum... https://ratsun.net/forum/53-720/ ... or perhaps the Project Datto ... https://ratsun.net/forum/6-project-datto/  ... Both allow pictures to be posted. Looking forward to seeing you there and welcome to Ratsun.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.