Jump to content

njp.18

Members
  • Posts

    61
  • Joined

  • Last visited

Profile Information

  • Cars
    '72 521

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

njp.18's Achievements

Contributor

Contributor (5/14)

  • Reacting Well Rare
  • Dedicated Rare
  • Conversation Starter Rare
  • First Post Rare
  • Collaborator Rare

Recent Badges

41

Reputation

  1. okay, I was supposed to measure the free play when the slave was empty tho right?
  2. just checked and no sound of rubbing. when installing the slave, I was supposed to measure the 2mm of free play when there was no fluid in the cylinder, correct? Cuz right now, there's no free play but I would think that's because I can't push the rod any further cuz its filled with fluid?
  3. my new slave cylinder came with a new push rod so I did replace it. I have the clearance of the push rod/clutch arm a tad bit more than 2mm which is why I was wondering if you guys have any idea on if more or less free play/ having the rod longer or shorter would cause difficulty shifting... so I know which way to adjust it if it can any effect on shifting gears
  4. there was a nut below the shifter under the car that was loose causing the washer to rattle around. tightened it up and no noise. and just out of curiosity, if the slave rod is too short, that would cause shifting into gears to be more difficult right, or if the rod is too long?
  5. I replaced the slave cylinder and the shift boot and took it for a drive and now have this sound coming from the shifter area. Is anyone familiar with this? I do not have the spring on the slave yet as mine broke taking it off and I do have a little more than 2mm gap when slave is bottomed out and clutch lever arm is pushed back. Heres a link with the video of the sound im talking about. https://docs.google.com/presentation/d/1twBmhjcS74Xx8PPHnNwXCq0SCwuB3-KttVAoangBxaQ/edit?usp=sharing
  6. I had went to the Nissan dealer at first and the parts guy had told me that I would have had to buy 10 of them so I said forget about it and that's when I came home and hopped on the forum but then found out that if I ordered it from my own computer, it'd allow me to order just 1 of them so should be all good, thanks guys
  7. do you have any of the springs you'd be willing to sell?
  8. lmao yea I probably shouldn't of got an autozone one but we'll so how it goes.
  9. @datzenmike @d.p Do I have to fill the new slave with fluid before I install it?
  10. if the push rod should be pushed into the slave all the way, how will I be able to wiggle it out 2mm?
  11. hey guys, I got a 521 as my first project car so I don't know much but I got my old slave off as it was leaking and am putting on my new one and have a question regarding where I should have the 1/16th inch of play. I understand that I push the rod as far down into the slave as it will go and then push the fork as far away from the truck as it can go but then, Should I have the nut on the rod where that the fork is 1/16inch away from being as far back as it can go Or have the nut on the rod be where the fork is 1/16 inch away from as far forward as it can go? Or neither? haha. let me know, thanks guys.
  12. ordered one from them yesterday, thank u
  13. Does anyone know of a shift boot thatll fit the 521? I want to order the stock looking rubber one but all I can find are the ones on eBay/ amazon that I've heard are too small for the hole...
  14. On the same end that I included a photo of correct? I don't see anywhere where another spring can be attached to though. Unless they were just slipped over the cable but what use would that do.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.