Jump to content

Lonewolf1990

Members
  • Content Count

    121
  • Joined

  • Last visited

Everything posted by Lonewolf1990

  1. Alright datsun fam, I seen videos of datsun ppl adding a pruis electric power steering , has anyone done it ??
  2. Alright datsun fam, so I have a working 350 small block engine, and was wondering if or have heard of anyone done this engine swap in datsun 620
  3. i bought all three from oreillys brand new , the spring and pin come come loose
  4. Everytime it has failed it’s because the fuel pump springs has came loose
  5. alright datsun fam i need advice! i went through 4 mechanical fuel pumps and im already over it what are good options of electric fuel pump for a 77 620 lb20 engine running a weber 32/36
  6. alright datsun fam its time for me to installed a electric fuel pump i already went through 3 mechanical pumps this year so what options of fuel pumps do i have? i have a 77 620 lb20 engine and im running A WEBER 32/36
  7. hows it going datsun fam so i have seen videos of datsuns in Thailand that have have used a electric power steering from a 09 Prius , has anyone done that conversion over here in the u.s?
  8. ok so i installed a new waterpump , check my hoses and belt everything is snug and tight , and im still running into the same issues, my truck heats up when i drive
  9. Ok Datsun fam I have a 77 620 and my thermostat housing cracked , I’m looking to find a new one and I can only find a l18 one on eBay , will that fit my motor? Will I have issues using it?
  10. Yes I have checked the hoses they do not collapse , I did get the truck tuned and timed correctly , no the heater hoses have not been joined together , yes the fan belt is tight , when I spin the fan it’s , 1/2 a turn
  11. alright datsun fam so my truck still goes the h when driving but cools down when im at a stop , i already changed the thermostat, just added a 3 row radiator and a electric fan the stock fan, im still running to the same issue, what could be the issue?
  12. so my 77 datsun 620 turn signals stopped working, my fuses are new, i checked the wires they are good, what can be the issues please help
  13. yes correct i adjusted the plastic nut and the door was able to lock much easier
  14. i was able to fix it be taking out the whole locking sections and drown it in wd-40 and i also adjusted the nut that is connected to the door handle lever
  15. thank you guys i was able to get the door fixed
  16. i have installed two new key locks on my passenger door and im still having issues to get it to lock, i have removed the panels and and check that everything was connected and in place but im still having issues , when i turn the key to the lock postion i see that the rod will not click into the down position but does fine when i turn it to the open position any ideas to fix the issue?
  17. anyone know of site that can build a replica tachometer or know if anyone knows one that will fit flush in the stock tachometer hole
  18. i do have those wires u are talking about i will try to connect to those instead of the alternator, ill send pics as soon as i can
  19. yes the carb is brand new from box and yeah i got the throttle link correct i followed every videos and reading on it to leave some slack also
  20. another question about the smog pump, can i just cap the hoses or do i completely remove it?
  21. the car was running fine before this, but the stock carb gave out and i decided to do the upgrade, its a weber DGEV, i have the 12 volt wire connected to the alternator , thats what i seen videos of
  22. yes the two piece adapters that came with the kit, i used blue locitie everything and made sure its really snug
  23. sorry for the missing info its a new legit weber from redline
  24. alright datsun fam, so i got my electric Weber mounted on a 510 intake and headers installed on my LB20 engine and i was able to get the truck started but it sounded horrible either the rpm was really low or really high or it sounds like it starving for air , i tried tuning it but no luck , i cant get the Weber correct , ill try to start the truck again and it will run for a second then cut off, or it will stay running on but the engine is shaking so badly , any tips to fix this issue please help!! also can anyone spare pics of how they have there weber setup and where they have vacuum lines
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.