Jump to content

Justin620datsun

Members
  • Content Count

    41
  • Joined

  • Last visited

Community Reputation

15 OK

About Justin620datsun

  • Rank
    Newbie
  • Birthday 09/11/1995

Profile Information

  • Gender
    Male
  • Location
    Grants Pass
  • Cars
    1979 datsun 620
  • Interests
    Radio controlled cars and working on my datsun.

Recent Profile Visitors

90 profile views
  1. Justin620datsun

    620 coolant system help.

    Yes I believe so. I had heat and everything prior to this. And no a/c. I checked the fuses they look fine. And yes the fan is working. Its blowing cold air now though.
  2. Justin620datsun

    620 coolant system help.

    So I was driving home yesterday and my truck blew off a hose. (Little one above the water pump). Luckily I was already in my spot. I shut it off immediately. It doesn't overheat but now my heater isn't pushing hot air out. I topped the coolant off, left the cap off for awhile to get bubbles out but it didnt help. I let it run for a good 15 minutes or so. The temperature stayed where it usually does but I just dont have heat. Any suggestions? Thanks again. If it's not one thing its another with it.
  3. Justin620datsun

    New to me 620

    Great info. On my next days off I will try this. Thanks. No lights are left on so I'm thinking it's a loose wire or something.
  4. Justin620datsun

    New to me 620

    took her for drive today. I installed a "kill switch" not so much for protection but to cut power while I'm not driving it. In case I have a drain of power somewhere. I'm thinking my ignition cylinder might be bad? Like I said it's a pain to get started sometimes even with the jump box I have. But seems to only do it in the morning. I'm stumped. Any suggestions on how to track this issue down?
  5. Justin620datsun

    New to me 620

    Yeah mine does the same thing. And damn that's what I was afraid of. I'll just deal with it for now. But I'm having another startup issue. Surprise surprise I know. When I go to start my truck usually in the morning but its random. It wont start. No crank, nothing. But I hook my jump box up to it it tries to start. My starter cranks for a second and then stops. Could my ignition solenoid or switch be bad? It is frustrating because it will be fine for a few days and then something else happens. Any ideas? Keep in mind if checked all the connections to the alternator, battery and starter which I replaced of course. So what could it be? I'll try to get a video tomorrow. Do you guys think I have a draw somewhere?
  6. Justin620datsun

    New to me 620

    Where the glass goes into the door. Half of them are missing and the others are dry rotted.
  7. Justin620datsun

    New to me 620

    Sweet! That was my biggest issue. So my window seals for the door are pretty toast. And recommendations for brand and where to get them?
  8. Justin620datsun

    New to me 620

    Ok as long as I dont run into issues with parts and title stuff it being possible different year cab and chassis I'm not worried about it. It is interesting how they did things back then. I'm unsure of the numbers down there. They dont look much cleaner in person. Anyways I put new spark plugs, cap,and rotor on it yesterday. Seems to have helped the dieseling a lot. I'm happy with it now. I have a slight valve cover gasket leak which doesn't surprise me. What brand do you guys recommend? Btw thanks for all the info on this old girl.
  9. Justin620datsun

    New to me 620

    Ok. And that isn't the tail pipe. It looks like a camper tie down point or something. The exhaust stops at the muffler under the bed for some reason. So it's a 78? Just sold in 79 then?
  10. Justin620datsun

    New to me 620

    also this isn't factory is it?
  11. Justin620datsun

    New to me 620

    So my truck might have been a camper at some point? Or could it have had the bed instead?
  12. Justin620datsun

    New to me 620

    Ok. I dont know a lot about the history on these things. Great info and good to know stuff.
  13. Justin620datsun

    New to me 620

    And my fan has 7 blades if I counted correctly.
  14. Justin620datsun

    New to me 620

    [/url Just went out and took these. Sorry if they came out blurry. Also found these manuals under the seat.
  15. Justin620datsun

    New to me 620

    There's a delete plate above the "switches" for the heater and such. The radio was mounted on the center console in front of the shifter with a small delete plate as well. I'll take a picture when I get home.
×

Important Information

By using this site, you agree to our Terms of Use.