Jump to content

saleach

New Members
  • Content count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About saleach

  • Rank
    Newbie

Profile Information

  • Location
    Houston
  • Cars
    Datsun 510, Honda s2000
  1. saleach

    280zx struts

  2. saleach

    280zx struts

    Hey Everyone, quick question on the 280zx swap that I have not yet seen mentioned. I bought my 510 with a coilover kit and what i believe to be 510 strut casings/spindle (i have stock 510 brakes) It wont let me upload a picture but they are have a red spring, gold adjusters, a red anodized screw casing and galvanized strut casing. Similar to T3 but different height adjstment and strut casing. I am unsure what brand of coilover this is (was told it was troy ermish with T3 camber plates but I dont see a similar product on his site. any help to ID this setup is appreciated). My question is, can I keep the current 510 arm/spindle assembly and just put on the 280zx hub and brakes? Is the strut casing removable, allowing me to pull over the 280zx strut casings and spindle with the rest of the assembly and put on the current coilovers? I have a guy selling the 280zx assembly and master cylinder for cheap but I want to be sure they will work with the coilovers I already have.
  3. saleach

    CARPET

    sorry to bump an old thread, but are these kits still in production? I have sent a PM but it's been a few weeks and no response. Is there an email to contact 71Dimer? Thanks!
  4. saleach

    510 Dash lights (not working)

    Good news everyone! I was able to troubleshoot the power from the green and white wire all the way back to the fuesbox. Once at the fusebox, I had 3 issues that were preventing power getting to the switch: 1. the fuse holder contacts were loose (this is why it powered on and off intermittently). I tightened those up and they held the fuse much better. 2. The green and white wire going to the fuse underneath the box had the insulation damaged and was shorting out, causing the fuse to blow. Wrapping it with electrical tape fixed the problem. 3. The crimp contact inside the connector was loose for the green/white wire. If you shook it with the light on, they would flicker and sometimes go out. I cut up a paperclip and carefully stuffed it in there and it firmed it up. I am happy to report the lights are working. Position 1: no lights. Position 2: dash lights, parking and tail lights. Position 3: inner headlights and dash/parking/tail lights. Position 3+turn signal brights illuminates the outer most lights. Thanks for the help everyone! Next task: Wiring an aftermarket horn to the existing wiring/relay.
  5. saleach

    510 Dash lights (not working)

    Thanks again for the replies! I have a meaningful update in that I have checked the green and white wire and verfieid that it is NOT bringing power to the switch. The only terminal that has power is the red and white cable. I also found another burnt plug (looks like the red and white wire again) and It shared a spot next to the green/white cable. I replaced the plug but again to no avail. Using the test light at the fuse box all fuses have power except for the top 2 on the right side when looking from the front of the car back. (Both the headlamps) At this point i am going to take out the dash, and unwrap the entire length of cable wrapping and look for shorts. Again, thanks for the help and any additional advice is appreciated.
  6. saleach

    510 Dash lights (not working)

    Thanks again for the replies! I have a meaningful update in that I have checked the green and white wire and verfieid that it is NOT bringing power to the switch. The only terminal that has power is the red and white cable. I also found another burnt plug (looks like the red and white wire again) and It shared a spot next to the green/white cable. I replaced the plug but again to no avail. Using the test light at the fuse box all fuses have power except for the top 2 on the right side when looking from the front of the car back. (Both the headlamps) At this point i am going to take out the dash, and unwrap the entire length of cable wrapping and look for shorts. Again, thanks for the help and any additional advice is appreciated.
  7. saleach

    510 Dash lights (not working)

    Thanks again for the reply mike. The connector between the headlight switch and the harness was burnt up in one spot so i cut and repinned a new connector but to no avail. The switch does not do anything in the second position, and the outer headlights only come on when the switch is pulled all the way out. I was able to take the switch apart (thanks for the tip on being careful) but did not see anything broken. I cleaned the contacts with rubbing alcohol and q-tips really well and reassembled everything. Unfortunately it didnt fix the second position energizing everything. I also checked the blue/green wire to the switch using a test light and it did not have power. I also took apart the headlight relay for any broken connections but found none. Then, I poked around looking for shorts or broken grounds but came up empty. What is meant by “parking lights”? Also, are there any other points i can troubleshoot ? I’d like to be 100% before I spend $50 on a old switch that may not be the culprit.
  8. saleach

    510 Dash lights (not working)

    Thanks a ton for the reply. This is very helpful. So it looks like the problem may be with the headlight switch. When i pull it out 1 time, nothing happens (no lights) when I pull it out a second time, the front headlights (highbeams? Outer most headlights) come on. I tried jiggling the light switch (good suggestion) but to no avail. I suppose it’s possible that the lightswitch has failed entirely. To make matters worse, I somehow lost power to my brake lights now as well as reverse lights, so the only lights I have on the rear of the car are turn signals. Headlights/high beams still work. I am worried that I am working backwards and will never make inspection at this point lol Edit: brake lights were a blown fuse. However, i noticed that onthe high beam/turn signal switch, there is a black wire with green stripe that appears to have been soldered/terminated somewhere and I cant find where. It looks like it is ground for the switch according to the wiring diagrams. (This is not the green with black stripe wire, it’s black with green stripe.) I will continue to look for this connection point and report my findings.
  9. saleach

    510 Dash lights (not working)

    Hey everyone! Sorry to bump an old thread but after extensive searching this is the closest thread I could find to my issue and didn’t want to make a new thread. Backstory: new 510 owner of a 1972 510 with sr20de swap. 2 previous owners and neither of them were electricians judging by the wiring jobs. When i first got the car the gauge lights and tail lights worked (idk about high beams as it only had the two outer headlights.) After about 20 mins of bumpy, lowered riding, the dash lights and tail lights cut out. Then, they would come back on every so often, particularly under hard acceleration. At this point, they are never on. I have taken apart the dash and looked through and cleaned up connections where I could. Similarly, I have replaced the fuses, cleaned contacts of the relay, checked the board of the gauges for breaks, checked the truck and side markers for shorts (i dont have side markers since i have IMSA flares), etc. I am 90% sure it’s a loose connection due to the fact that it came off and on periodically after it initally failed for no reason. At this point I am running out of ideas. My specific questions are: 1. Does the headlight relay make an audible “click” when the brights are switched even without inner headlights installed? 2. Are there typical wiring failures that I can look for that may shake loose? 3. Is there anything under the car that could impact this phenomenon? The car is super low and im not used to driving this low and have hit my share of bumps. This could have rattled something loose but could it have been something under the car? Sorry for the long post, I wanted to piggyback on this thread since it didn’t already have a happy ending. Any help is appreciated!
×

Important Information

By using this site, you agree to our Terms of Use.