Jump to content

frank88

Members
  • Content Count

    173
  • Joined

  • Last visited

Everything posted by frank88

  1. As above, does anyone know the original selling prices? Specifically for a 76 long bed l20b, califodnia model I found this website but I can't access it from the UK! https://www.google.com/url?sa=t&source=web&rct=j&url=https://www.nadaguides.com/Cars/1975/nissan-datsun/620/pickup/values&ved=2ahUKEwjYpZeVntrsAhWNgVwKHTVUB9IQFjAXegQIHhAC&usg=AOvVaw1pKnOG_S57HuFXjb-Ve2nV&cshid=1603989420373 Cheers
  2. Time Left: 4 hours and 50 minutes

    • WANTED
    • USED

    Hi guys, Does anyone have a spare metal brake master cylinder reservoir cap? Not sure if there are different types? It doesn't have a thread as such, just twists on

    $999

  3. This is a good write up but just two chuck in my two cents. I didnt bother about the 90 deg or 180 deg light pattern. Nor did I remove any lenses. Just bought the right leds and put them in and all fitted great. I did trim the heater bulbs to fit but they are made of resin so no bother trimming the lens bit
  4. Seems I have the transistorised ignition which I think is stock for the 76 California trucks. Can't find any pics of the coil ballast though so will investigate when I get the whole loom out It's all working well so I am not going to touch it, just maybe move it to a tidier place. Still not sure if the smaller box with the same Hiatchi logo on is part of the same circuit
  5. Time Left: 13 days and 2 hours

    • WANTED
    • USED

    A set of 620 beauty rings for the headlights wanted 🙂 Thanks

    $50

  6. I think the little box connected to my dizzy could be a remote ignitor box maybe. I'll open the dizzy tonight and get a picture. Thanks for info on voltage regulator. Maybe the other small box is the flasher unit? I'm going to investigate further tonight.
  7. Hi guys, so the situation is I have weird wiring issues, damaged wires and wires that go nowhere. I figured I might try a full rewire with a couple of simple fuse/relay setups. I know it isn't really needed but I like a project and it will help me learn and hopefully not be scared of wiring any more. So with that said, I have some basic, stupid and ridiculous questions incoming to help get me started. Go easy on me...... Ignoring my old jap coke can decoration, my first question is about the resistor(?) next to the coil. most pics i have see. have two wires comin
  8. Cheers for the info guys. I'll try that Mike. Not even sure my vac feed will cut it anyway so will try it out. Hopefully itll be on the road in the next few months
  9. Hi guys, Quick question, with an after market pedal box with its own master cylinders, you obviously dont run the stock booster right? So surely the effort is a lot more? I have a 620 with drums all around and currently the booster interferes a but with my r1 carbs. Cheers, Frank
  10. Sorry Mike, this is my truck. I'm still struggling with embedding images! Or do you mean that's what it's from? I'm a bit confused with mine because I think we have discussed before how my 76 truck shouldn't have an l20b in it. And when I turned over the coil bracket, it says 510 on it. It's working now anyway 🙂
  11. 9 years later this helped my diagnose my non starting issue in 10 mins! The only screw which I didnt replace was the hardest to get to and the one that had crumbled away! I have this setup for reference although I think it might be from a 510? https://imgur.com/gallery/7ucWsyv
  12. Not 100% but it is on my to check list. I'll get the fuses changed, and the bulbs and see how it is
  13. Thanks Mike I will be doing all of this. The 8w bulbs are expensive over here but I have a new set. 5w are mich more common. Once I've got it all working nice US spec, I'm going to convert to UK spec. Flashing side repeaters and no flashing rear brake lights etc
  14. Just need a bit of help of where to start with this because I dont know what's normal and not. Here are the symptoms: When I turn the right turn signal on there is a 5 second delay then it starts working but seems slow to me. The hazard lights are also slow and a bit sporadic. The left wing mounted light doesnt work so I guess that might have something to do with it? When the headlights are on, the signal lights are much dimmer. Finally.... how do you put full beam on!?
  15. Yea I cleaned that out. There is also a drain on each so i guess draining the bowls every now and again in situ could help
  16. Quick update, thank you to the first suggestions.... running on 4 now. Was blocked pilot jet. Cleaned them all, not sure how I forgot to do that when I refreshed the carbs. Had a confidence knock but back on it now! Cheers guys
  17. Interesting because I dumped the old and put about 10l of new in and that's it in terms of cleaning it! Looked clean inside when I used a torch though
  18. frank88

    LS1 into 620?

    Have you seen the ls swap 620 on YouTube being built at the moment? They've taken a very cut heavy approach! Channel is called "Built"
  19. Well initially after fitting the r1 carbs it started and ran like a dream. Then suddenly didn't! So yea I guess that is number 1 suspect. I did have a rummage around under the dash looking at some shady wiring but there seems to be spark so cant think what i could have knocked and affected under there. I tested the fuel pump and that's running fine too so I'll have to take the carbs apart
  20. Thanks for the tips, I'll be checking all of this. Yes new gas, new fuel lines and new fuel filter (with the new pump). Carbs have been cleaned and check prior to fitting but I'll will check jets for blockages. Is it worth blocking the vac nipples on the inlet too?
  21. Hi all, So the story is, the truck was apparently running fine when i bought it two years ago but has sat in my garage since then. I put some r1 carbs on it and it started and idled perfectly 4 or 5 times. I left it for a week and when i started it, it's running on 3 cylinders. It will only run with the choke on and dies if you try to give it some gas. I have pulled the leads on the distributer and all are sparking strong, number 4 lead makes no difference so that cylinder isn't firing. Could I please have a list of things to check/eliminate to help me solve
  22. Long overdue update although not a huge amount has happened. For around a year the truck sat in my garage whilst I worked on my house but I have now made some progress. I was also going though the documents the other day and have the original buyers pack. Shows it had done 81k miles in 1981! This is what i started with, L20b engine with all the emissions stuff With the lower temperatures stopping the engine firing up without spraying petrol into it, i decided i wanted something to do so read all 80 pages of the r1 carb thread! Then I started collec
  23. In a funny turn of events, due to ka24s being very hard to come by here and the fact I'm 99% done on an r1 carb swap, I'm going to have to pass these up! Crazy luck he's having giving these away!
  24. frank88

    620 Windshield

    This probably isn't helpful at all but I messaged Pilkington glass and they still have the moulds and sell them. This was the uk branch though, not sure if the sell in the us.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.